Dell VxRail : Échec de la mise à niveau de VxRail avec le message « Code de retour de script incorrect : 1"
Resumen: Lors d’une mise à niveau de VxRail pour 4.7.X, 7.0.X ou 8.0.X, l’erreur suivante s’affiche : « Bad script return code : 1".
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Lors d’une mise à niveau de VxRail pour 4.7.X, 7.0.X ou 8.0.X, l’erreur suivante s’affiche : « Bad script return code : 1 ».
lcm-web.log :
Lors de la vérification du VAMI vCenter, le service de stockage axé sur le profil VMware vSphereindique que l’intégrité est « Intègre avec des erreurs » (ou des avertissements) et que l’état est « Démarré ».
Pour vérifier le VAMI, connectez-vous en tant qu’utilisateur root au VAMI vCenter à partir d’un navigateur Web à l’aide de https://vCenter FQDN ou adresse IP :5480.
Cliquez sur Services.
lcm-web.log :
INFO : Starting adding new disk sdc
INFO : Checkiing whether sdc exists ...
INFO : No sdc disk on VXM, need to perform add.
INFO : Handling VM <VxM Name Here>
INFO : Get VM Storage Profile name VXRAIL-SYSTEM-STORAGE-PROFILE, id <Long string of characters>.
INFO : Vm profileId is <Long string of characters>.
ERROR : Failed to add a new disk: (vodl.fault.SystemError)
{
dynamicType = <unset>
dynamicProperty = (vmodl.DynamicProperty) []
Msg = 'A general system error occurred: PBM error occurred during Pre-ReconfigureCallback: Fault cause: vmodl.fault.SystemError\n;\n'
faultCause = <unset>
faultMessage = (vmodl.LocalizableMessage) []
Reason = 'PBM error occurred during Pre-ReconfigurCallback: Fault cause: vmodl.fault.SystemError\n;\n'
}
Pour vérifier le VAMI, connectez-vous en tant qu’utilisateur root au VAMI vCenter à partir d’un navigateur Web à l’aide de https://vCenter FQDN ou adresse IP :5480.
Cliquez sur Services.
Causa
Le service de stockage axé sur le profil VMware vSphere n’a pas démarré correctement. Cela entraîne des problèmes d’affichage des profils de stockage dans vSphere Client.
Resolución
Pour résoudre ce problème, suivez les étapes ci-dessous pour redémarrer vCenter (et PSC pour 6.7 et versions antérieures) :
si la version de vCenter est 6.7.X ou une version antérieure :
Si la version de vCenter est 7.0 ou ultérieure :
si la version de vCenter est 6.7.X ou une version antérieure :
- Dans le client vSphere, cliquez sur la machine virtuelle vCenter.
- Recherchez l’hôte sur lequel la machine virtuelle vCenter est en cours d’exécution.
- Cliquez ensuite sur la machine virtuelle PSC.
- Migrez la machine virtuelle PSC vers le même hôte ESXi que la machine virtuelle vCenter.
- Connectez-vous en tant qu’utilisateur root à l’hôte ESXi à partir d’un navigateur Web à l’aide de https et du FQDN ESXi ou de l’adresse IP de gestion.
- Cliquez avec le bouton gauche de la souris sur Virtual Machines.
- Cliquez avec le bouton gauche de la case correspondant à la machine virtuelle vCenter.
- Cliquez avec le bouton gauche de la souris sur Actions.
- Survolez le système d’exploitation invité.
- Cliquez avec le bouton gauche de la souris sur Arrêter.
- Cliquez avec le bouton gauche de la souris sur Virtual Machines.
- Cliquez avec le bouton gauche de la case correspondant à la machine virtuelle vCenter pour l’effacer.
- Cliquez avec le bouton gauche de la case correspondant à la machine virtuelle PSC.
- Cliquez avec le bouton gauche de la souris sur Actions.
- Survolez le système d’exploitation invité.
- Cliquez avec le bouton gauche de la souris sur Redémarrer.
- Patientez environ 3 à 5 minutes.
- Cliquez avec le bouton gauche de la case correspondant à la machine virtuelle PSC pour l’effacer.
- Cliquez avec le bouton gauche de la case correspondant à la machine virtuelle vCenter.
- Cliquez avec le bouton gauche de la souris sur Actions.
- Survolez le système d’exploitation invité.
- Cliquez avec le bouton gauche de la souris sur Redémarrer.
Si la version de vCenter est 7.0 ou ultérieure :
- Dans vSphere, cliquez sur la machine virtuelle vCenter.
- Recherchez l’hôte sur lequel la machine virtuelle vCenter est en cours d’exécution.
- Connectez-vous en tant qu’utilisateur root à l’hôte ESXi à partir d’un navigateur Web à l’aide de https et du FQDN ESXi ou de l’adresse IP de gestion.
- Cliquez avec le bouton gauche de la souris sur Virtual Machines.
- Cliquez avec le bouton gauche de la case correspondant à la machine virtuelle vCenter.
- Cliquez avec le bouton gauche de la souris sur Actions.
- Survolez le système d’exploitation invité.
- Cliquez avec le bouton gauche de la souris sur Redémarrer.
Propiedades del artículo
Número del artículo: 000218572
Tipo de artículo: Solution
Última modificación: 14 jul 2026
Versión: 2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.