Dell VxRail: O upgrade do VxRail falha com "Bad script return code: 1"
Resumen: Durante um upgrade do VxRail para 4.7.X, 7.0.X ou 8.0.X, há o seguinte erro "Bad script return code: 1".
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Durante um upgrade do VxRail para 4.7.X, 7.0.X ou 8.0.X, há o seguinte erro "Bad script return code: 1".
lcm-web.log:
Ao verificar o VAMI do vCenter, o serviço de armazenamento orientado por perfil do VMware vSphere mostra a integridade como "Healthy with errors" (ou warnings) e State como "Started".
Para verificar o VAMI, faça log-in como root no VAMI do vCenter a partir de um navegador da Web usando https://vCenter FQDN ou endereço IP:5480.
Clique em Serviços.
lcm-web.log:
INFO : Starting adding new disk sdc
INFO : Checkiing whether sdc exists ...
INFO : No sdc disk on VXM, need to perform add.
INFO : Handling VM <VxM Name Here>
INFO : Get VM Storage Profile name VXRAIL-SYSTEM-STORAGE-PROFILE, id <Long string of characters>.
INFO : Vm profileId is <Long string of characters>.
ERROR : Failed to add a new disk: (vodl.fault.SystemError)
{
dynamicType = <unset>
dynamicProperty = (vmodl.DynamicProperty) []
Msg = 'A general system error occurred: PBM error occurred during Pre-ReconfigureCallback: Fault cause: vmodl.fault.SystemError\n;\n'
faultCause = <unset>
faultMessage = (vmodl.LocalizableMessage) []
Reason = 'PBM error occurred during Pre-ReconfigurCallback: Fault cause: vmodl.fault.SystemError\n;\n'
}
Para verificar o VAMI, faça log-in como root no VAMI do vCenter a partir de um navegador da Web usando https://vCenter FQDN ou endereço IP:5480.
Clique em Serviços.
Causa
O serviço de armazenamento orientado por perfil do VMware vSphere não foi iniciado corretamente. Isso está causando problemas de visualização de perfis de armazenamento no vSphere Client.
Resolución
Para resolver esse problema, siga as etapas abaixo para reiniciar o vCenter (e o PSC para a versão 6.7 e abaixo):
se a versão do vCenter for 6.7.X ou inferior:
Se a versão do vCenter for 7.0 ou mais recente:
se a versão do vCenter for 6.7.X ou inferior:
- No vSphere Client, clique na VM do vCenter.
- Localize em qual host a VM do vCenter está sendo executada.
- Em seguida, clique na VM do PSC.
- Migre a VM do PSC para o mesmo host ESXi que a VM do vCenter.
- Faça log-in como root no host do ESXi a partir de um navegador da Web usando https e o FQDN ou endereço IP de gerenciamento do ESXi.
- Clique com o botão esquerdo do mouse em Máquinas virtuais.
- Clique com o botão esquerdo na caixa da VM do vCenter.
- Clique com o botão esquerdo do mouse em Ações.
- Passe o mouse sobre o sistema operacional convidado.
- Clique com o botão esquerdo do mouse em Desligar.
- Clique com o botão esquerdo do mouse em Máquinas virtuais.
- Clique com o botão esquerdo na caixa para limpar a VM do vCenter.
- Clique com o botão esquerdo na caixa da VM do PSC.
- Clique com o botão esquerdo do mouse em Ações.
- Passe o mouse sobre o sistema operacional convidado.
- Clique com o botão esquerdo do mouse em Reiniciar.
- Aguarde cerca de 3 a 5 minutos.
- Clique com o botão esquerdo na caixa para limpar a VM do PSC.
- Clique com o botão esquerdo na caixa da VM do vCenter.
- Clique com o botão esquerdo do mouse em Ações.
- Passe o mouse sobre o sistema operacional convidado.
- Clique com o botão esquerdo do mouse em Reiniciar.
Se a versão do vCenter for 7.0 ou mais recente:
- No vSphere, clique na VM do vCenter.
- Localize em qual host a VM do vCenter está sendo executada.
- Faça log-in como root no host do ESXi a partir de um navegador da Web usando https e o FQDN ou endereço IP de gerenciamento do ESXi.
- Clique com o botão esquerdo do mouse em Máquinas virtuais.
- Clique com o botão esquerdo na caixa da VM do vCenter.
- Clique com o botão esquerdo do mouse em Ações.
- Passe o mouse sobre o sistema operacional convidado.
- Clique com o botão esquerdo do mouse em Reiniciar.
Propiedades del artículo
Número del artículo: 000218572
Tipo de artículo: Solution
Última modificación: 14 jul 2026
Versión: 2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.