NVP vProxy: Todos los respaldos de VMware con fallas "curl_easy_perform" arrojaron el error 60: "Certificado SSL"

Resumen: Todos los respaldos de máquinas virtuales (VM) de NetWorker VMware Protection (NVP) fallan. El trabajo informa que el certificado utilizado por el vProxy es incorrecto.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Todos los respaldos de VM fallan con el siguiente error en los registros de acciones:

MM/DD/YY HH:mm:SS Action backup vmware-vproxy 'ACTION_NAME' has initialized as 'vproxysave job' with job id 2080030
MM/DD/YY HH:mm:SS Starting nsrvim.
MM/DD/YY HH:mm:SS Calling the nsrvim program to collect the inventory data.
MM/DD/YY HH:mm:SS Setting default timeout 1800.
MM/DD/YY HH:mm:SS Using a timeout of 1800 seconds for the nsrvim request. Minimum timeout is 360 seconds. Maximum timeout is 3600 seconds.
MM/DD/YY HH:mm:SS Getting list of VM work items.
MM/DD/YY HH:mm:SS Transport mode selected from the user for backup: 'Auto'.
MM/DD/YY HH:mm:SS Saving the backup data in the pool 'POOL_NAME'.
MM/DD/YY HH:mm:SS Received the media management binding information on the host 'NW_SERVER_NAME'.
MM/DD/YY HH:mm:SS Connected to the nsrmmd process on the host 'NW_SERVER_NAME'.
MM/DD/YY HH:mm:SS VM_NAME: Perform incremental backup.
MM/DD/YY HH:mm:SS VM_NAME: Using backup mode 'VSS'.
MM/DD/YY HH:mm:SS VM_NAME: Unable to start backup on vProxy 'VPROXY_NAME': libCURL: function "curl_easy_perform" returned error 60: "SSL certificate problem: invalid CA certificate" .
MM/DD/YY HH:mm:SS Summary of VMs: after iteration 1
MM/DD/YY HH:mm:SS   0 canceled backups
MM/DD/YY HH:mm:SS   1 failed backups
MM/DD/YY HH:mm:SS   0 VMs not in inventory
MM/DD/YY HH:mm:SS   0 successful backups
MM/DD/YY HH:mm:SS   0 waiting backups
MM/DD/YY HH:mm:SS   0 running backups
MM/DD/YY HH:mm:SS   0 savesets output to next action

Los registros de acciones se encuentran en NetWorker Server:

Esta falla se produce en NetWorker Server; no hay registros en el vProxy que correspondan a la falla anterior. El problema se produce antes de que se establezca una sesión con el vProxy.

No hay problemas de comunicación entre vProxy y NetWorker Server, ambos hosts pueden resolverse entre sí y conectarse mediante el puerto 9090: NVP vProxy: Solución de problemas de conectividad de red para operaciones de respaldo y restauración

Causa

Este problema se observó en un entorno en el que NetWorker Server no se había reiniciado en muchos meses. La causa presunta son los certificados obsoletos que se utilizan entre NetWorker Server y vProxy. 

Resolución

Restablezca los certificados que utiliza NetWorker Server.

  1. En un símbolo del sistema elevado en el servidor de NetWorker, detenga los servicios de NetWorker:

Linux: nsr_shutdown o systemctl stop networker
Windows: net stop nsrexecd /y

 

  1. Transfiera los siguientes archivos a otro directorio del host:

Linux:

/nsr/sec/authcerts/SERVER-NAME_9090
/nsr/sec/authcerts/SERVER-NAME.cacert

Windows (valor predeterminado):

C:\Program Files\EMC NetWorker\nsr\sec\authcerts\SERVER-NAME_9090
C:\Program Files\EMC NetWorker\nsr\sec\authcerts\SERVER-NAME.cacert 

 

  1. Reinicie NetWorker Server.
NOTA: El host se debe reiniciar; volver a iniciar los servicios no resuelve el problema. 

 

  1. Después de reiniciar el host, ejecute el siguiente comando desde un símbolo del sistema elevado: nsrauthtrust -H NETWORKER_SERVER_NAME -P 9090

Este comando vuelve a crear el archivo /nsr/sec/authcerts/SERVER-NAME_9090 de NetWorker.

 

  1. Reinicie los respaldos de VM.

Si las fallas de respaldo persisten, es posible que sea necesario volver a registrar los vProxies para restablecer el certificado en el host vProxy: NVP vProxy: Cómo cancelar o volver a registrar un dispositivo
vProxyVolver a registrar el vProxy agrega el /nsr/sec/authcerts/SERVER-NAME.cacert regresar al servidor NetWorker Server.

Información adicional

Productos afectados

NetWorker

Productos

NetWorker Family
Propiedades del artículo
Número del artículo: 000410390
Tipo de artículo: Solution
Última modificación: 31 dic 2025
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.