NetWorker: El respaldo de Windows 2012 falla para DISASTER_RECOVERY con "save: Se produjo un error al guardar los savesets de recuperación ante desastres"

Resumen: En este artículo, se explica la falla del saveset DISASTER_RECOVERY:\ durante los respaldos de Windows 2012 causada por un repositorio WMI de Windows dañado. NetWorker no puede recuperar los datos del fabricante del sistema a través de WMI, lo que genera el error. Arreglar o recompilar el repositorio de WMI y actualizar el cliente de Windows resuelve el problema. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

DISASTER_RECOVERY:\ no se puede realizar un respaldo en una máquina con Windows 2012.
Todos los demás savesets (como unidades, carpetas o archivos) se completan correctamente.

Los savesets WINDOWS ROLES AND FEATURES y Respaldo de unidades críticas correctamente.

El único error que se muestra es

save: Error occured while saving disaster recovery save sets

La última entrada en la salida guardada es (no se muestra ningún error):

create_ossr_info_file: Calling get_system_manufacturer_info
Cuando se ejecuta el respaldo en el nivel de depuración 5, se observan los siguientes errores hacia el final del registro:
machine_name: WINDOWS ROLES AND FEATURES:\ level=full, 6636 KB 00:00:02     21 files
Completed savetime=1442493321
09/17/15 14:35:23.961661 Unregistered session id:2, fd:1420, idx:1, ssn_max_pollfd:1, 1(512)
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to disk_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to pool_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to volume_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to partition_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to adapter_free_list()
86024:save: Error occured while saving disaster recovery save sets.

Causa

Durante DISASTER_RECOVERY:\ respaldos, NetWorker utiliza el WMI (componente del sistema operativo) para obtener información de la máquina del cliente (como el nombre de dominio, el fabricante, el nombre de la máquina y la memoria física) que, a continuación, se completa en la DISASTER_RECOVERY:\ metadatos. En este caso, el WMI de la máquina está dañado y NetWorker no puede obtener los datos de WMI, lo que provoca una falla de respaldo.

El problema es con Windows WMI. La falla se produce cuando NetWorker utiliza una consulta WMI para obtener la información del fabricante del sistema que se almacenará con el DISASTER_RECOVERY:\ Metadatos de savesets.
 
Ejecución de Get-WmiObject Win32_Computersystem Powershell falla con un mensaje de operación no válido. Para verificar si WMI está dañado o no, ejecute el siguiente comando en Windows PowerShell en esa máquina.
 
Un buen resultado debe ser:
PS C:\> Get-WmiObject Win32_Computersystem

Domain         : emc.com
Manufacturer   : VMware, Inc.
Model          : VMware Virtual Platform
Name                : LIME
PrimaryOwnerName    : Windows User
TotalPhysicalMemory : 2146951168

Si aparece cualquier otro resultado, sugiere que WMI está dañado y no puede responder a las llamadas del sistema operativo. A continuación, se muestra un ejemplo de un WMI dañado:
PS C:\Users\Adam.Boesl> Get-WmiObject Win32_Computersystem
Get-WmiObject : Invalid class
At line:1 char:14
+ Get-WmiObject <<<<  Win32_Computersystem
    + CategoryInfo          : InvalidOperation: (:) [Get-WmiObject], ManagementException
    + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

Resolución

Los respaldos de Windows Server 2012 se enumeran como compatibles en las guías de compatibilidad de NetWorker. Revise las guías de compatibilidad de su versión de NetWorker: E-Lab Interoperability Navigator 2.0-HOME (debe iniciar sesión con su cuenta de soporte de Dell).
Sin embargo, este problema ocurre en el sistema operativo Windows. Las funcionalidades de soporte son limitadas para problemas a nivel del sistema operativo en plataformas que ya no son compatibles con su proveedor.

Asegúrese de que el SO del cliente tenga instaladas las últimas actualizaciones del SO. Si los respaldos del Servicio de instantáneas de volumen (VSS) continúan fallando, puede investigar los componentes de VSS. El administrador del sistema debe investigar los componentes de VSS y las funcionalidades del SO.  

Si el problema del sistema operativo no se puede resolver, realice respaldos de datos del sistema de archivos del cliente sin VSS.

  1. Configure las operaciones de guardado del cliente para incluir lo siguiente: VSS:*=OFF:
    Respaldo de un cliente de Windows sin VSS 
    NOTA: Ver:> el modo de diagnóstico debe estar habilitado en NMC para ver la configuración de las operaciones de guardado.
  2. Actualice el campo savesets del cliente para incluir solo archivos, carpetas o volúmenes. Por ejemplo:
PRECAUCIÓN: Sin VSS, no puede realizar respaldos basados en bloques (BBB) ni respaldos coherentes de DISASTER_RECOVERY:\. Los datos del sistema de archivos se pueden respaldar sin VSS; sin embargo, no sería posible realizar una recuperación de bajo nivel (BMR) sin respaldos de DISASTER_RECOVERY:\.

Información adicional

Productos afectados

NetWorker

Productos

NetWorker
Propiedades del artículo
Número del artículo: 000018662
Tipo de artículo: Solution
Última modificación: 27 abr 2026
Versión:  5
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