Data Domain: Disk Unknown

Resumen: This article explains the conditions under which a disk may report as "Unknown" on Data Domain systems and provides steps to identify and resolve the issue.

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Síntomas

  • A disk appears with the state "Unknown" in the system.
  • The issue may affect:
    • A single disk in the system controller (head unit) or attached storage
    • All disks in a newly attached enclosure
    • A disk recently replaced due to failure

Causa

A disk may report as "Unknown" due to one of the following reasons:

  • A newly installed disk is not (yet) recognized by the system.
  • A disk in the system is unreliable (for example, a failed disk reports an 'unknown' state).
  • An entire enclosure has been added but not yet integrated into the RAID group.
  • A single disk replacement has not been properly initialized.

Resolución

Follow the steps below based on the scenario:

  1. Verify Disk State

  2. Single Disk Reports "Unknown" (and is NOT a new replacement disk)

    • Check active system alerts (alerts show current) and disk state (disk show state)
      • If the disk is reported as failed, and is in an 'unknown' state - replace the 'unknown/failed' disk
    • If the 'unknown' disk is a newly installed (replacement) disk, see Step 4.
  3. All Disks in a New Enclosure Report "Unknown"

    • This is expected behavior for a newly added shelf.
      • Follow the relevant Shelf Hardware Guide to get the 'Unknown' disks added to storage capacity.
    • A basic overview of the steps to add a new shelf: Obtain relevant licensing, add the storage to the required storage tier (active, cloud) and then expand the filesystem,
  4. Single Disk Reports "Unknown" After Replacement

    • Attempt a rescan of drives. Run command # disk rescan
    • Verify status of drive from DD-CLI # disk show state
      • If the disk has become 'In-use' and the alert has not cleared, manually clear the alert using DD-CLI # alerts clear alert-id <alert-id>
      • If the disk remains 'unknown' - run the # disk unfail <encl.disc>  command to transition the disk to a spare state.
  5. Need Additional Assistance

    • If the issue remains unresolved:
      • Contact your contracted support provider and raise a service request.

Información adicional

 

 

     

    Productos afectados

    Data Domain

    Productos

    Data Domain
    Propiedades del artículo
    Número del artículo: 000043258
    Tipo de artículo: Solution
    Última modificación: 28 oct 2025
    Versión:  4
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