AppSync: El plan de servicio falla o muestra un error durante la edición debido a "VPLEXClientFactory: no se pudo obtener el bloqueo dentro de 5000/10000MILLISECONDS"

Resumen: Un plan de servicio que involucra VPLEX puede fallar con el error "VPLEXClientFactory: no se pudo obtener el bloqueo dentro de 5000 MILISEGUNDOS/10000 MILISEGUNDOS". Además, durante la edición del plan de servicio y en la fase de creación y copia, al seleccionar el clúster de VPLEX, el error aparece como se indicó anteriormente. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

El plan de servicio falla o aparecen errores durante la edición de los ajustes del plan de servicio. El error es el siguiente:

Para los clientes de AppSync 4.1.0.x, el error es:

concurrent access timeout on VPLEXClientFactory - could not obtain lock within 5000MILLISECONDS

Para los clientes de AppSync 4.2.0.x, el error es:

concurrent access timeout on VPLEXClientFactory - could not obtain lock within 10000MILLISECONDS

En los registros del servidor de AppSync, se muestra el siguiente error:

<DATE & TIME> ERROR [default task-38] [org.jboss.as.ejb3.invocation] [AppSync Server] [] WFLYEJB0034: EJB Invocation failed on component VPLEXClientFactory for method public com.emc.archway.service.vplex.VPLEXClient com.emc.archway.service.vplex.VPLEXClientFactory.getClient(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.vplex.VPLEXManagementServer) throws com.emc.archway.errorMessages.ArchwayException: javax.ejb.ConcurrentAccessTimeoutException: WFLYEJB0241: EJB 3.1 PFD2 4.8.5.5.1 concurrent access timeout on VPLEXClientFactory - could not obtain lock within 10000MILLISECONDS

 

Causa

La respuesta de VPLEX no se recibe dentro del tiempo de espera agotado codificado de AppSync.

Esto parece ser un problema de rendimiento de VPLEX. En situaciones en que, en cierto punto, VPLEX tarda en responder y AppSync no puede obtener el cliente VPLEX dentro de la ventana de tiempo de espera agotado codificado de 5 o 10 segundos. Por lo tanto, esto está causando la falla del plan de servicio.

Además, el motivo por el que se produce el error mientras se edita el plan de servicio es que AppSync intenta volver a descubrir la información de VPLEX antes de que se muestre en la interfaz de usuario y, debido a un problema de rendimiento de VPLEX, se agota el tiempo de espera.

Este tiempo de espera agotado existe en AppSync 4.1 y 4.2.

AppSync 4.1.0.x tiene un valor de tiempo de espera agotado de 5000 MILISEGUNDOS (5 segundos).
AppSync 4.2.0.x tiene un valor de tiempo de espera agotado de 10 000 MILISEGUNDOS (10 segundos).

 

Resolución

Actualice a AppSync 4.3 o posterior, en la cual se elimina la comprobación de tiempo de espera agotado.

 

Productos

AppSync
Propiedades del artículo
Número del artículo: 000193937
Tipo de artículo: Solution
Última modificación: 31 oct 2025
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.