AppSync: vCenter perdió la conectividad con AppSync, ya que el archivo cacert se dañó
Resumen: AppSync perdió la conectividad con vCenter; el motivo de esto fue la corrupción del archivo cacert.
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Síntomas
1. Se perdió la conectividad con vCenter.
2. El redescubrimiento de vCenter falla; además, no podemos eliminar el vCenter.
3. El restablecimiento de las credenciales aparece en el cuadro de diálogo con el siguiente error:
La revisión de los registros del servidor con respecto al registro de fecha y hora de la prueba muestra los eventos de la siguiente manera:
2. El redescubrimiento de vCenter falla; además, no podemos eliminar el vCenter.
3. El restablecimiento de las credenciales aparece en el cuadro de diálogo con el siguiente error:
Exception in VCConnectionCache:failed to connect: Keystore was tampered with, or password was incorrect : Password verification failed
La revisión de los registros del servidor con respecto al registro de fecha y hora de la prueba muestra los eventos de la siguiente manera:
DEBUG [default task-29] [com.emc.archway.securedcommands.ArchwayEJBInterceptor] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> Bean level security checking for public java.util.UUID com.emc.archway.securedcommands.vmware.ValidateCreateVCenterServerCommandSecuredBean.validateAndCreate(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.host.vcenterserver.VCenterServer) throws java.rmi.RemoteException,com.emc.archway.errorMessages.ObjectAlreadyExistsException,com.emc.archway.errorMessages.ArchwayException,com.emc.archway.acl.AuthorizationConfigException DEBUG [default task-29] [com.emc.archway.service.vc.VCEntityLockCommandBean] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> EJB default - 1Locking entityID:https://FQDN/sdk for update INFO [default task-29] [com.emc.archway.service.vc.VCConnectionCache] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> getURLConnection::https://FQDN/sdk creating a new connection to url:https://vmcsxxxx.xxx.co.xx/sdk as no cached connection available INFO [default task-29] [com.emc.archway.service.vc.BasicVCConnection] [Appsync Server Name] [] 2b3e6a5c-f7e2-41f7-ba01-229fcb6d6417->>> establishing TLS connection DEBUG [default task-29] [com.emc.archway.service.vc.EnableSecurity] [Appsync Server Name] [] 2b3e6a5c-f7e2-41f7-ba01-229fcb6d6417->>> getTrustMangerForCertificates using keystoreName: install_dir:\EMC\AppSync\jboss\_jre\lib\security\cacerts ERROR [default task-29] [com.emc.archway.service.vc.VCConnectionCache] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> Exception in VCConnectionCache:failed to connect: Keystore was tampered with, or password was incorrect : Password verification failed INFO [default task-29] [com.emc.archway.service.eventservice.EventServiceBean] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> EVENT [VM_000156]: Unable to create a new connection to vCenter server:https://FQDN/sdk failed to connect: Keystore was tampered with, or password was incorrect : Password verification failed(METADATA: TYPE-ERROR, TIME-Time-Stamp.738+0400NATIVETIME-2022-05-17 , HOST-Appsync Server Name, PHASE-, THREAD=default task-29, USER-s911987, CATEGORY-GENERIC, SESSIONID-iGywYTLkg9bspkRYZYlvF9gD8vP78L0__2c6_0N2) INFO [default task-29] [com.emc.archway.service.vc.VCEntityLockCommandBean] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> EJB default - 1Unlocking entityID:https://FQDN/sdk for update INFO [default task-29] [com.emc.archway.service.vc.VCServiceBean] [Appsync Server Name] [] 0dbfcdd0-69a8-43b2-9555-e8133aa932ca->>> Exception while getting connection to vc ::Unable to create a new connection to vCenter server:https://FQDN/sdk. Error: failed to connect: Keystore was tampered with, or password was incorrect : Password verification failed: com.emc.archway.service.eventservice.exceptions.ConnectionManagerException: Unable to create a new connection to vCenter server:https://FQDN/sdk. Error: failed to connect: Keystore was tampered with, or password was incorrect : Password verification failed at deployment.archway-ear.ear.vcservice-4.3.0.0-SNAPSHOT.jar//com.emc.archway.service.vc.VCConnectionCache.getConnection(VCConnectionCache.java:236)
Causa
En el caso anterior, una aplicación de terceros dañó el archivo cacert, lo que causó el problema.
Resolución
Siga los pasos que se indican a continuación para validar y reemplazar el archivo cacer dañado por el archivo cacert en buen estado.
1. Para validar si el archivo ca-cert está dañado.
Si el comando anterior falla con el mensaje "Keystore was tampered with, or password was incorrect : Error de verificación de contraseña:" y, a continuación, el archivo está dañado y se debe reemplazar; por lo tanto, continúe.
2. Para validar si el archivo de reemplazo está en buen estado.
El comando anterior debe ejecutarse correctamente. (Si se producen estos errores, debe comunicarse con el soporte).
3. Reemplace el archivo dañado por uno en buen estado:
1. Para validar si el archivo ca-cert está dañado.
Ejecute el siguiente comando en cmd(admin) en el servidor de AppSync:
install_dir:\EMC\AppSync\jre\bin>keytool.exe -list -v -keystore Install_dir:\emc\appsync\jboss\_jre\lib\security\cacerts (enter changeit for the pwd).
Si el comando anterior falla con el mensaje "Keystore was tampered with, or password was incorrect : Error de verificación de contraseña:" y, a continuación, el archivo está dañado y se debe reemplazar; por lo tanto, continúe.
2. Para validar si el archivo de reemplazo está en buen estado.
Ejecute el siguiente comando en cmd(admin) en el servidor de AppSync:
install_dir:\EMC\AppSync\jre\bin>keytool.exe -list -v -keystore install_dir:\emc\appsync\jre\lib\security\cacerts (enter changeit for the pwd)
El comando anterior debe ejecutarse correctamente. (Si se producen estos errores, debe comunicarse con el soporte).
3. Reemplace el archivo dañado por uno en buen estado:
Ejecute el siguiente comando en cmd(admin) en el servidor de AppSync
copy install_dir:\EMC\AppSync\jre\lib\security\cacerts install_dir:\EMC\AppSync\jboss\_jre\lib\security
Si el comando anterior no funciona, realice la copia de cacerts manualmente desde:
install_dir:\EMC\AppSync\jre\lib\security\cacerts to install_dir:\EMC\AppSync\jboss\_jre\lib\security
4. Importe el archivo ca-cert recién reemplazado.
Ejecute el siguiente comando en cmd(admin) en el servidor de AppSync
install_dir:\EMC\AppSync\jboss\_jre\bin>keytool.exe -importcert -file install_dir:\EMC\AppSync\jboss\_jre\lib\security\cas.crt -keystore install_dir:\EMC\AppSync\jboss\_jre\lib\security\cacerts -storepass changeit -alias appsync -noprompt
5. Reinicie los servicios e intente iniciar sesión en AppSync
Nota:
- Debe reemplazar el install_dir con el directorio de instalación de AppSync donde sea que se mencione.
- (Se recomienda realizar el respaldo de cacerts de install_dir:\EMC\AppSync\jboss\_jre\lib\security, de modo que podamos evitar volver a ejecutar los mismos comandos si el archivo se daña nuevamente).
Productos
AppSync, AppSyncPropiedades del artículo
Número del artículo: 000199992
Tipo de artículo: Solution
Última modificación: 14 may 2026
Versión: 6
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