PowerEdge: vSphere ESXi: Cómo preparar el host habilitado para TPM para cambios de hardware a fin de evitar PSOD

Resumen: Si los hosts ESXi utilizan el módulo de plataforma segura (TPM), en este artículo, se proporcionan los pasos que se deben seguir mientras SSH aún puede acceder al host ESXi antes de cualquier cambio de hardware. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Instrucciones

Síntomas:
Después de realizar el mantenimiento de hardware, incluido el reemplazo de componentes (por ejemplo, la batería CMOS, la CPU, etc.), es posible que experimente errores de pantalla púrpura (PSOD) cuando arranque el respaldo del host.

Ejemplo de mensaje de diagnóstico de pantalla púrpura

Causa raíz:
A partir de la versión 7.0u2, ESXi utiliza TPM 2.0 para proteger las configuraciones del sistema a través del "sellado de TPM". Solo se puede acceder a la configuración con el mismo chip de TPM utilizado inicialmente.

Para evitar esto, es necesario recopilar la clave de recuperación de los hosts habilitados para la seguridad del TPM antes de realizar el reemplazo.

Instrucciones:

  1. Acceda mediante SSH al host ESXi
  2. Verifique si el TPM está instalado y la opción "TPM Security" está activada en el BIOS:
[root@host1:~] esxcli hardware trustedboot get
   Drtm Enabled: true
   Tpm Present: true
  1. Obtenga la clave de recuperación mediante la ejecución del siguiente comando:
esxcli system settings encryption recovery list

Salida de la clave de comando

Nota: La clave de recuperación es el segundo conjunto de números que se muestran: 16 grupos, cada uno con seis dígitos, como se resaltó anteriormente
 
  1. Asegúrese de guardar la clave de recuperación en un lugar seguro para usarla en el futuro.
Nota: Si la clave de recuperación no está disponible, la única opción es reinstalar ESXi.

 

 

En esta etapa, puede reemplazar la parte de manera segura y, si tenía la PSOD anteriormente, puede seguir los pasos que se indican a continuación para resolver el problema.

Pasos:

  1. Reinicie ESXi y, a continuación, presione MAYÚS+O cuando se le solicite:

Pantalla de reinicio

  1. Agregue la configuración de arranque con lo siguiente de la clave de recuperación recopilada de Requisitos previos: 
encryptionRecoveryKey=######-######-######-######-######-######-######-######-######-######-######-######-######

Ejemplo de mensaje adjunto

Nota: No elimine la información que ya está presente al principio del mensaje.
 
Al final del UUID de arranque existente, agregue un espacio seguido de la información de encryptionRecoveryKey , como se muestra en la captura de pantalla anterior.
  1. Presione Intro para continuar con el proceso de arranque del host.
  2. Acceda mediante SSH al host y ejecute el siguiente comando para escribir los cambios en el disco:
[root@host1:~] /sbin/auto-backup.sh

Productos afectados

VMware

Productos

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Propiedades del artículo
Número del artículo: 000318876
Tipo de artículo: How To
Última modificación: 03 sept 2025
Versión:  2
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