ECS: OBS: ID del síntoma 12024: Error en la conexión de la prueba geográfica

Resumen: Esta alerta se agrega para mostrar que falló la conexión de prueba geográfica.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Código del síntoma Gravedad Descripción Condición
12024 ERROR

La prueba de conectividad TLS/HTTP falló durante una llamada local/remota. Resuelva el problema de conexión remota para la conexión TLS/HTTP. Las conexiones fallidas son las siguientes:

<node IP> to <node IP>: caused by: <error message>
<node IP> to <node IP>: caused by: <error message>

Falló la conexión de prueba geográfica

Causa

Esta alerta se envía en los siguientes casos:

Caso 1: Switch de VDC único a caso HTTPS

  • Se actualizó el sistema a 4.3
  • El usuario intenta probar la conexión para ver si puede cambiar la conexión geográfica a HTTPS, pero encuentra un error.

Caso 2: Varios VDC cambian a un caso HTTPS

  • Se actualizó el sistema a 4.3
  • El usuario cargó TLS geográfico, CA y certificados para todos los VDC siguiendo la guía de administración.
  • El usuario intenta probar la conexión para ver si puede cambiar la conexión geográfica a HTTPS, pero encuentra un error.

Caso 3: Reserva de uno o varios VDC a mayúsculas y minúsculas HTTP

  • Se actualizó el sistema a 4.3 y se cambiaron correctamente las conexiones geográficas a HTTPS.
  • Para algunos casos de emergencia, el usuario desea utilizar como reserva la conexión geográfica a HTTP.
  • El cliente utiliza la API proporcionada para iniciar el servidor HTTP del receptor geográfico.
  • El usuario intenta probar la conexión HTTP para ver si puede utilizar la conexión geográfica de reserva a HTTP, pero encuentra un error.

Resolución

Para los casos 1 y 2, cambie al caso HTTPS. Utilice la siguiente API para comprobar nuevamente si la conexión de prueba es correcta o no.

// SSH to one node of the cluster
cluster_ip=localhost

// Get authentication token of management API
auth_token=$(curl -s -k -I -u root:ChangeMe https://${cluster_ip}:4443/login | grep X-SDS-AUTH-TOKEN | awk '{print $NF}')

// For switch to HTTPS case, use testConnection API. 
curl -kv -X 'GET'   'https://localhost:4443/rest/v1/geoConnection/testConnection'   -H 'accept: application/json'   -H 'X-SDS-AUTH-TOKEN: '${auth_token}

Si arroja 200, la conexión de prueba está bien. De lo contrario, devuelve un mensaje de error como el siguiente (el mensaje de error puede ser diferente):

{"description":"Test HTTPS connection failed during remote call. Please resolve remote connection problem for HTTPS connection. The failed connections are:","failure":[{"source_ip":"10.10.10.10","source_node_name":"node01.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.10","target_node_name":"node01.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.10","source_node_name":"node01.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.11","target_node_name":"node02.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.12","source_node_name":"node03.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.12","target_node_name":"node03.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.12","source_node_name":"node03.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.13","target_node_name":"node04.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.14","source_node_name":"node05.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.14","target_node_name":"node05.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.14","source_node_name":"node05.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.15","target_node_name":"node06.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.16","source_node_name":"node07.d* Connection #0 to host localhost left intact
omain.com","source_zone_name":"vdc1","target_ip":"10.10.10.16","target_node_name":"node07.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.16","source_node_name":"node07.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.17","target_node_name":"node08.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"}]}

 

Para el caso 3, recurra al caso HTTPS. Utilice la siguiente API para comprobar si la conexión HTTP de prueba es correcta o no.

// SSH to one node of the cluster
cluster_ip=localhost

// Get authentication token of management API
auth_token=$(curl -s -k -I -u root:ChangeMe https://${cluster_ip}:4443/login | grep X-SDS-AUTH-TOKEN | awk '{print $NF}')

// For fallback to HTTP case, use testHttpConnection API. 
curl -kv -X 'GET' 'https://localhost:4443/rest/v1/geoConnection/testHttpConnection' -H 'accept: application/json' -H 'X-SDS-AUTH-TOKEN: '${auth_token}

Si arroja 200, la conexión de prueba está bien. De lo contrario, devuelve un mensaje de error como el siguiente (el mensaje de error puede ser diferente):

{"description":"Test HTTP connection failed during remote call. Please resolve remote connection problem for HTTPS connection. The failed connections are:","failure":[{"source_ip":"10.10.10.10","source_node_name":"node01.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.10","target_node_name":"node01.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.10","source_node_name":"node01.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.11","target_node_name":"node02.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.12","source_node_name":"node03.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.12","target_node_name":"node03.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.12","source_node_name":"node03.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.13","target_node_name":"node04.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.14","source_node_name":"node05.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.14","target_node_name":"node05.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.14","source_node_name":"node05.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.15","target_node_name":"node06.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.16","source_node_name":"node07.d* Connection #0 to host localhost left intact
omain.com","source_zone_name":"vdc1","target_ip":"10.10.10.16","target_node_name":"node07.domain.com","target_zone_name":"vdc1","error_message":"java.net.ConnectException: Connection refused (Connection refused)"},{"source_ip":"10.10.10.16","source_node_name":"node07.domain.com","source_zone_name":"vdc1","target_ip":"10.10.10.17","target_node_name":"node08.domain.com","target_zone_name":"vdc2","error_message":"java.net.ConnectException: Connection refused (Connection refused)"}]}

Comuníquese con el soporte de Dell si ve mensajes de error como los anteriores.

Propiedades del artículo
Número del artículo: 000445543
Tipo de artículo: Solution
Última modificación: 14 may 2026
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.