PowerStore: Pérdida de la administración del clúster después del reinicio de dos nodos de varios dispositivos
Resumen: PowerStore: Pérdida de administración del clúster después del reinicio de nodo doble de varios dispositivos en un clúster
Síntomas
Si varios dispositivos de un clúster experimentan un reinicio de nodo doble simultáneamente, puede producirse una pérdida del acceso de administración.
Incluso después de que los nodos vuelvan a estar en línea.
Causa
Después de un reinicio de nodo doble de un dispositivo, la ruta de control puede aparecer antes que la ruta de datos y puede entrar en un estado degradado.
- Si esto ocurre en varios dispositivos simultáneamente y se pierde el quórum, hay una ventana de tiempo en la que la ruta de control puede salir del modo degradado en los dispositivos secundarios mientras la ruta de control aún está degradada en el principal.
- Esto provoca una falla cuando se sincroniza correctamente la base de datos con la base de datos secundaria, lo que deja al clúster en un estado en el que no se puede administrar.
Resolución
Solución
Está previsto corregir este problema en una versión futura.
Solución alternativa
1) Reinicie el nodo primario del dispositivo primario. Siga las instrucciones de reinicio del nodo en. Guía de procedimientos de apagado y reinicio
- Para identificar cuál de los dispositivos es el dispositivo primario, conéctese mediante SSH a cualquiera de los nodos y ejecute el svc_cluster_management comando:
[SVC:service@XXXXXXX-A user]$ svc_cluster_management GetClusterStatus
====================================================================
---APPLIANCE INFORMATION---
dell_service_tag : XXXXXXX
serial_number : XXXXXXXXXXXXXX
name : PowerStore-appliance-1
pacemaker_representation: appliance_fnmXXXXXXXXXXX
====================================================================
---CLUSTER STATUS---
local is master: True
master id: 1
---PACEMAKER APPLIANCE LIST---
id: 1
name: appliance_fnmXXXXXXXXXXX
appliance icm ip address: XXXX:XXXX:XXXX:X:XXX:XXXX:XXXX:XXXX
online: True
En el ejemplo anterior (ID maestro: 1) Indica cuál es el dispositivo primario. Si "local es master: Verdadero" significa que el dispositivo local es el dispositivo principal.
- Para identificar cuál de los nodos es el nodo primario, conéctese mediante SSH como servicio a uno de los nodos del dispositivo y ejecute el svc_diag comando:
[SVC:service@XXXXXXX-A user]$ svc_diag list --info Node ID : A Appliance Friendly Name : PowerStore-appliance-1 Service Tag : XXXXXXX Model Number : PowerStore 3000T 900-564-101 Software Revision : 1.0.2.0.5.003 Management IP Address : XX.XX.XX.XX Discovery IP Address : XX.XX.XX.XX Data Path Primary : B SYM : B SSH Enabled : True
Los valores "Data Path Primary" y "SYM" identifican el nodo primario para el dispositivo. Tenga en cuenta que en el ejemplo anterior está conectado al nodo A. La salida anterior del nodo B es el nodo primario.
2) Compruebe que las múltiples rutas de todos los hosts estén configuradas correctamente.
3) Si el problema persiste, escale el problema al soporte técnico.