AppSync: El agente AppSync 4.2 se bloquea con ucrtbase.dll como el módulo con errores
Resumen: Cuando AppSync 4.2 está instalado, los usuarios pueden encontrar bloqueos intermitentes del agente. Estos bloqueos se caracterizan por una pérdida intermitente de comunicación con el agente durante la ejecución de un plan de servicio y se observará una serie de eventos en los registros de eventos de aplicación y del sistema del host. Este problema se puede observar en Windows 2016 y 2019. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Los usuarios pueden experimentar bloqueos intermitentes debido al agente AppSync 4.2 o AppSync 4.2.0.1. Este problema se puede identificar mediante los siguientes síntomas.
En primer lugar, se puede ver el siguiente error en los eventos de un plan de servicio de AppSync:
En primer lugar, se puede ver el siguiente error en los eventos de un plan de servicio de AppSync:
AppSync server failed to connect to agent host: <Host Name>. Ensure the agent host is up and reachable from the AppSync server. If this is a Windows agent host, ensure AppSync Host Plug-in service is in running state.
Cuando se comprueba el host, se pueden ver los siguientes mensajes en el registro de eventos de la aplicación del host:
03/05/2021 12:56:47 PM Information <Host Name> 1001 Windows Error Reporting Fault bucket , type 0 Event Name: BEX64 Response: Not available Cab Id: 0 Problem signature: P1: APPSYN~1.EXE P2: 4.2.0.0 P3: 602b55dd P4: ucrtbase.DLL P5: 10.0.10240.16390 P6: 55a5b718 P7: 0000000000064388 P8: c0000409 P9: 0000000000000005
Causa
Esto puede deberse a que el sistema host ejecuta una versión de ucrtbase.dll que no es compatible con AppSync. O bien, se debe a un error de código en el agente AppSync.
Resolución
Realice los siguientes pasos para resolver este problema:
- Ejecute todas las actualizaciones acumulativas de Windows y las actualizaciones de seguridad en el host y reinicie el host de ser necesario.
Asegúrese de que el archivo ucrtbase.dll tenga las siguientes versiones mínimas:
Para Windows Server 2016, verifique que la versión mínima de ucrtbase.dll sea 10.0.14393.2097.
Para Windows Server 2019, verifique que la versión mínima de ucrtbase.dll sea 10.0.17763.719.
Reinicie el servicio del plugin del host y vuelva a ejecutar el plan de servicio.
Para Windows Server 2019, verifique que la versión mínima de ucrtbase.dll sea 10.0.17763.719.
Reinicie el servicio del plugin del host y vuelva a ejecutar el plan de servicio.
- Si el problema no se resuelve en este punto, se creó una corrección para este problema. Esta se puede adquirir abriendo una solicitud de servicio.
Propiedades del artículo
Número del artículo: 000185071
Tipo de artículo: Solution
Última modificación: 09 may 2026
Versión: 5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.