PowerFlex: Errores de I/O del cliente cuando se utiliza la replicación

Resumen: Los clientes o servidores experimentan errores de I/O en dispositivos respaldados por PowerFlex. El back-end general (MDM/SDS) parece estar en buen estado. Se está utilizando la replicación de PowerFlex y hay algunos errores de RPO en 1 o más de los RCG. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

  • Sin capacidad degradada o fallida
  • No hay SDS desacoplados ni dispositivos SDS que informen errores.
  • Sin MDM desconectados

Se está utilizando la función de replicación.
Una o más alertas en la UI de informa los siguientes errores:

Major - The RCG consistent image is too large to be consumed by the destination in one piece.

Minor - Remote Consistency Group RPO Exceeded
Los registros de eventos de MDM pueden informar lo siguiente:
2024-06-11 15:55:56.592000:0001566:RPL_PD_CAP_UTILIZATION_MINOR     WARNING  Protection Domain ID <pd_id> Replication journal capacity is at MINOR utilization level
2024-06-11 16:20:12.848000:0001567:RPL_PD_CAP_UTILIZATION_MAJOR     ERROR    Protection Domain ID <pd_id> Replication journal capacity is at MAJOR utilization level
2024-06-11 17:19:57.272000:0001584:RPL_PD_CAP_UTILIZATION_CRITICAL  CRITICAL Protection Domain ID <pd_id> Replication journal capacity is at VERY_HIGH utilization level
2024-06-11 17:52:26.352000:0001585:RPL_PD_CAP_UTILIZATION_CRITICAL  CRITICAL Protection Domain ID <pd_id> Replication journal capacity is at CRITICAL utilization level
...
2024-06-11 16:25:14.381000:0001576:RPL_CG_MOVED_TO_SLIM_MODE        INFO     Replication Consistency Group ID <rcg_id> entered slim mode
2024-06-11 18:27:29.738000:0001586:SDR_CRITICAL_CAP_CHANGE          ERROR    SDR ID <sdr_id>) handling user data changed discarded old user data and stopped to accumulate new user data due critical capacity
 

Impacto 

Los clientes no pueden acceder a los volúmenes interceptados para replicación.


Causa

Es posible que se produzca un defecto de software poco frecuente cuando el componente MDM y el SDR no están de acuerdo en los contadores internos relacionados con la capacidad del registro. Esta discrepancia puede hacer que el MDM anule la asignación de capacidad de registro adicional cuando la capacidad del SDR está llena, lo que podría provocar errores de I/O en clientes o servidores que utilicen dispositivos respaldados por PowerFlex.

Resolución

Se requiere un reinicio gradual de todos los componentes de SDR y se debe cambiar la propiedad del MDM en el sistema de origen para resolver el problema.

Reinicie los componentes de SDR:

1) Identifique todos los SDR:

scli --query_all_sdr

2) Ingrese al modo de mantenimiento en la SDR:

scli --enter_sdr_maintenance_mode --sdr_name <name>

3) Valide que el SDR esté completamente en modo de mantenimiento mediante la ejecución del comando del paso 1.

4) Reinicie el componente SDR.

pkill sdr

5) Repita esto para todos los SDR en el sitio de origen.
 

Una vez que se reinicien todos los SDR, cambie la propiedad del MDM:

#3.x
scli --switch_mdm_ownership --new_master_mdm_name <name>
 
#4.x
scli --switch_mdm_ownership --new_primary_mdm_name <name>

*Si lo desea, la propiedad se puede transferir de vuelta al servidor MDM original.

Valide que ya no se informen los errores de I/O en el cliente o los servidores. Si el cliente ingresó a un sistema de archivos de solo lectura, es posible que el cliente/servidor requiera un reinicio.

Hasta que se pueda determinar la causa, también se recomendará finalizar todos los RCG en el sistema de origen.

Si los errores de I/O continúan después de aplicar los pasos anteriores, comuníquese con el equipo de ingeniería de PowerFlex.

Información adicional

Versiones afectadas

PowerFlex 3.x

PowerFlex 4.x

Problema corregido en la versión

PFMP 4.5.3

Productos afectados

PowerFlex Software
Propiedades del artículo
Número del artículo: 000227849
Tipo de artículo: Solution
Última modificación: 19 ene 2026
Versión:  7
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.