Integrated Dell Remote Access Controller ile Redfish API
Resumen: Bu makalede, Redfish API'yi Dell integrated Remote Access Controller ile kullanma hakkında yol gösterici bilgiler yer alır.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Redfish, RESTful arayüzü belirten Dağıtılmış Yönetim Araştırma Grubu (DMTF) standart teknik özellikleri ve şemasıdır. Çözümleri mevcut araçlarla entegre etmek için JSON ve OData kullanır.
Causa
Çözüm bölümüne bakın.
Resolución
Aşağıdaki belge, Entegre Dell Uzaktan Erişim Denetleyicisi (iDRAC) için Redfish API'sinin kullanımını açıklar.
Redfish'teki DMTF Malzemeleri
Redfish belgeleri ve teknik raporları ile birlikte iDRAC RESTful API'si
-
iDRAC9 Redfish API Rehberi:
-
En yeni iDRAC Redfish API rehberi için developer.dell.com adresine gidin. Servers (Sunucular) bölümünde iDRAC9 Redfish API'yi seçin.
-
developer.dell.com/apis üzerindeki 4.xx, 5.xx, 6.xx veya 7.xx sürümlerinin herhangi birine erişmek için en yeni API rehberine gidin ve sürüm serisini seçin.
-
3.00.00.00 veya 3.40.40.40 gibi önceki sürümlerin hepsi için dell.com/idracmanual adresine gidin.
-
-
iDRAC8 Redfish API Rehberi:
-
Dell EMC PowerEdge Redfish API teknik raporu tanıtımı (İngilizce)
-
iDRAC RESTful API teknik raporu ile RESTful Sunucu Yapılandırması (İngilizce)
-
PowerShell teknik raporu ile Redfish'i Otomatikleştirme (İngilizce)
- OEM geliştiricileri için Redfish Şemaları (İngilizce)
- iDRAC Redfish SSS belgesi.
- Komut dosyası örnekleri için GitHub'da iDRAC Redfish Scripting (iDRAC Redfish Komut Dosyası Oluşturma) sayfasına gidin.
Redfish otomatikleştirme araçları ile iDRAC RESTful API
Productos afectados
Networking, Servers, iDRAC7, iDRAC8, iDRAC9Propiedades del artículo
Número del artículo: 000178045
Tipo de artículo: Solution
Última modificación: 18 dic 2025
Versión: 21
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.