Avamar: MCS recibe mensajes "OutOfMemory"

Resumen: Avamar Management Console Server (MCS) recibe mensajes "Sin memoria" debido a un archivo NVRAM grande desde una máquina virtual.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Los respaldos físicos y de VMware programados parecen no responder.

Pueden aparecer en la ventana Avamar Administrator Activity como en ejecución, pero sin ningún cambio en los bytes de progreso.

El servidor de consola de administración (MCS) informa una condición de "memoria insuficiente" y la interfaz de usuario puede tardar en responder.

Los clientes de VMware no se registran durante largos períodos de tiempo.

Causa

Durante el respaldo de máquinas virtuales, MCS carga los archivos de memoria de acceso aleatorio no volátil (NVRAM) en su javaheap para leer la configuración del BIOS.

El archivo NVRAM se encuentra en la misma ubicación que VMware *.vmdk Archivos que se encuentran en el almacén de datos.

En ocasiones, el archivo de NVRAM, que normalmente tiene un tamaño de solo unos pocos KB (menos de 10 KB), crece a alrededor de 1 MB o más.

Esto es suficiente para causar SQM javaheap para quedarse sin memoria.

 

Resolución

1. Inicie sesión en Avamar Utility Node y cargue las claves de administrador. Para obtener instrucciones sobre cómo cargar claves , consulte Avamar: Cómo iniciar sesión en Avamar Server y cargar varias claves.

2. Compruebe si el javaheap ya está configurado en 1,5 GB, lo que se indica con "-Xmx1536m" en la siguiente salida:

Nota: El valor "Xmx1536m" puede variar según el uso de la memoria.  
 
ps -elf | grep java | grep mcserver
0 S admin    13623     1  2  76   0 - 556102 -     16:54 pts/0    00:10:16
/usr/java/jre1.6.0_22/bin/java -Xmx1536m -XX:MaxPermSize=256m -server -ea -cp
.:/usr/local/avamar/lib/mcserver.jar:/usr/local/avamar/lib/asn_server.jar:/usr/local/avamar/lib/mail.jar:/usr/local/avamar/lib/activation.jar:/usr/local/avamar/lib/xercesImpl.jar:/usr/local/avamar...<snip>...
6.1.23.jar:/usr/local/avamar/lib/jetty-util-6.1.23.jar:/usr/local/avamar/lib/servlet-api-2.5.jar:/usr/local/avamar/lib/jsp-api-2.1.jar:/usr/local/avamar/lib/jsp-
 

3. Confirme si se informan mensajes "OutOfMemory" en el registro (debido a una NVRAM potencialmente grande):

grep -hi "OutOfMemoryError\|VMware" /usr/local/avamar/var/mc/server_log/mcserver.log*
Exception in thread "Thread-191" java.lang.OutOfMemoryError: Java heap space
        at java.util.Arrays.copyOf(Unknown Source)
        at java.io.ByteArrayOutputStream.write(Unknown Source)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.readVmFile(VmwareVirtualMachineFiles.java:386)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.getVirtualMachineFile(VmwareVirtualMachineFiles.java:109)
        at
com.avamar.mc.vmware.VmwareVirtualCenter.getVirtualMachineFile(VmwareVirtualCenter.java:902)
        at
com.avamar.mc.vmware.VmwareService.getNvramFileContent(VmwareService.java:2596)
        at com.avamar.mc.wo.JobScheduler._gotVmWork(JobScheduler.java:530)
        at com.avamar.mc.wo.JobScheduler.gotVmWork(JobScheduler.java:327)
        at com.avamar.mc.wo.DPNScheduler.gotVmWork(DPNScheduler.java:144)
 

4. Compruebe qué clientes tienen la NVRAM grande:

grep "nvramContent\=\"null\"" mcserver.log.*
 

Esta salida de ejemplo informa al cliente "informes de Company_1_Email-PDB""nvramContent="null"':

FINE: MCS to Client(10.n.n.64:39270) Response: <workorder work="backup" type="work" ack="yes" cid="8580a6233796c72a4a73b89f0d2ae5fb644fcbd0" sync="bg" 
wid="NFSSQLCluster-1350439200070" pid="vmimagew" pidnum="3016" msgver="5" sessionid="c61b498fdf57eaca6cadc760a3b7fbf6f7e89aea" 
targetCid="bae291d2ba3d3e3ea77d5394bcaa60da3a072463" targetUUID="500faaf4-8f4b-b5f2-1744-1277d19a79cf" vcCid="3a25059a880e1d22b981c5815858d3dc95312621" 
time="1350442682" customaction="" ><targetlist><path name="[nas_datastore_03] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="85899345920">
</path><path name="[nas_datastore_03_sqldb] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="171798691840"></path>
<path name="[nas_datastore_03_sqllogs] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="32212254720"></path></targetlist><directives> 
<flag type="string" name="encrypt" value="proprietary"  />  <flag type="string" name="encrypt-strength" value="cleartext"  />  <flag type="string" name="expire" 
value="1353034800"  />  <flag type="string" name="retention-type" value="daily,weekly,monthly,yearly"
....
"TRUE"scsi0:2.deviceType = "scsi-hardDisk"scsi0:2.present = "TRUE"scsi0:2.redo = ""migrate.hostlog = "
./Company_1_Email-PDB-b5986b60.hlog"scsi0:0.ctkEnabled = "TRUE"ctkEnabled = "TRUE"sched.scsi0:1.shares = "normal"
ethernet1.virtualDev = "vmxnet3"ethernet1.pciSlotNumber = "192"ethernet1.startConnected = "TRUE"
ethernet1.allowGuestConnectionControl = "TRUE"ethernet1.features = "1"ethernet1.wakeOnPcktRcv = "TRUE"
ethernet1.addressType = "vpx"ethernet1.generatedAddress = "00:00:56:8f:3f:b1"ethernet1.networkName = "
VM Network - 117"ethernet1.present = "TRUE""  nvramContent="null" prevBackup="null" snapshotDesired="always" prevSnapName="null" >
</vmInfo><vmDiskInfoList numDisks="3" > <vmDiskInfo capacityInKB="83886080" vmdkFilename="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" 
vmdkBaseFile="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" ordinal="1" srcOrdinal="-1" label="Hard disk 1" diskKey="2000" 
datastoreUrl="ds:///vmfs/volumes/e4b3f733-24646679/" datastore="nas_datastore_03"
Nota: Es posible que más de un cliente informe un valor nulo nvramcontent value, por lo que se deben revisar todas las instancias.
 

5. Una vez que el cliente o los clientes con NVRAM grande se identifican desde los registros:

un. Reinicie el cliente para que cree un nuevo archivo NVRAM.

b. Si el problema ocurre para el mismo cliente, cree una solicitud de servicio con el equipo de soporte técnico de Dell Technologies.

6. Si el mensaje de error persiste, consulte Avamar: Código del síntoma 22402 - Desc: No se pudieron guardar los datos del servidor de consola en el servidor (ruta de resolución) para la solución de problemas adicionales.

Productos afectados

Avamar

Productos

Avamar
Propiedades del artículo
Número del artículo: 000036926
Tipo de artículo: Solution
Última modificación: 07 oct 2025
Versión:  8
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.