SRM делает слишком много вызовов PAPI | HTTP, что приводит к увеличению количества FD и последующим 500 ошибкам в PowerScale

Resumen: SRM выполняет чрезмерные вызовы PAPI, приводящие к высокому числу FD и последующим 500 ошибкам в PowerScale, что приводит к сбою papi_d и http_d, что требует перезапуска управляющей программы. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Ошибки, появляющиеся в http на узле Isilon, обнаруженном в SRM; x.x.x.x — это IP-адрес сборщика SRM
 
2021-03-25T10:14:12+01:00 18.3 Isilon-4(id4) httpd[3254]: [auth_isilon:error] [pid 3254:tid 34510904832] [client x.x.x.x:58282] (403) User admin doesn't have logon privilege to service platform.
2021-03-25T10:14:16+01:00 18.3 Isilon-4(id4) httpd[3254]: [auth_isilon:error] [pid 3254:tid 34510904832] [client x.x.x.x:58618] (403) User admin doesn't have logon privilege to service platform.
2021-03-25T10:19:12+01:00 18.3 Isilon-4(id4) httpd[3254]: [auth_isilon:error] [pid 3254:tid 34511470080] [client x.x.x.x:59364] (403) User admin doesn't have logon privilege to service platform.

Causa

У пользователя администратора нет привилегий входа в систему для сервисной платформы.

Resolución

Предоставьте роль ISI_PRIV_AUTH администратору, который используется при обнаружении SRM.

Isilon-1# isi auth roles view admin
Privileges
             ID: ISI_PRIV_LOGIN_CONSOLE
      Read Only: True
 
             ID: ISI_PRIV_LOGIN_PAPI
      Read Only: True
 
             ID: ISI_PRIV_LOGIN_SSH
      Read Only: True
 
             ID: ISI_PRIV_SYS_SHUTDOWN
      Read Only: True
 
             ID: ISI_PRIV_SYS_SUPPORT
      Read Only: True
 
             ID: ISI_PRIV_SYS_TIME
      Read Only: False
 
             ID: ISI_PRIV_SYS_UPGRADE
      Read Only: False
 
             ID: ISI_PRIV_AUTH
      Read Only: True
 

Кроме того, можно создать нового пользователя с необходимыми ролями для SRM. 

Información adicional

ViPR SRM/Watch4Net. Какие привилегии необходимы для Isilon Discovery
https://www.dell.com/support/kbdoc/en-us/000030368/vipr-srm-watch4net-what-privileges-are-required-for-isilon-discovery?lang=en

Productos afectados

SRM, SRM
Propiedades del artículo
Número del artículo: 000185665
Tipo de artículo: Solution
Última modificación: 05 feb 2022
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.