Instalación de DPS: El respaldo de Avamar para máquinas virtuales almacenadas en Data Domain no se puede indexar

Resumen: DPSearch no puede indexar el respaldo de Avamar de máquinas virtuales almacenadas en Data Domain.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

DPSearch no puede procesar respaldos de máquinas virtuales realizados con Avamar y almacenados en Data Domain.

Se observan los siguientes errores en la carpeta Search-avamar-worker.log:

avtar Info <40174>: Multi-stream restore via cloning is enabled.
avtar Info <10632>: Using Client-ID='4af298f6f0b72f045f3ed91b4ceb7659636ba6fa'
avtar Info <40062>: GSAN connected via: IPv4, retrieved Data Domain IPv4 hostname = DataDomainHostname
avtar Info <10539>: Connecting to Data Domain Server "DataDomainHostname"(1)  (LSU: avamar-1554377407, User: "********")
avtar Warning <18125>: Calling DDR_OPEN returned result code:5037 message:illegal operation
avtar Error <10542>: Data Domain server "DataDomainHostname" open failed DDR result code: 5037, desc: illegal operation
avtar Error <10512>: Problem logging into the DDR server index:1
avtar Info <41359>: Backup #119 had been created by avtar version 19.4.100-116_327864 as plugin 3016-VMWare Image
avtar Info <5949>: Backup file system character encoding is UTF-8.
avtar Info <8745>: Backup from Linux host "/AvamarMachine/VirtualMachines/ClientMachine_1KMzhUOoPjaxweV3lNGRSg" (avproxy-XXXXXX) with plugin 3016 - Windows VMWare Image
avtar Info <5538>: Backup #119 label "MOD-1626356785880#1" timestamp 2021-07-15 19:33:06 IST, 0 files, 1,900 GB
avtar Warning <19046>: Unable to get ddr_files.xml for clientid ClientID and backupid BackupID
avtar Warning <19047>: Unable to retrieve DDR info for 'VMConfiguration'
avtar Error <5195>: Path "VMFiles/1/zMetadata.sql" not found in backup. (Exception looking up 'VMFiles/1/zMetadata.sql': Unable to set location information in direlem_iter for 'VMConfiguration')
avtar Info <9772>: Starting graceful (staged) termination, failed to restore (final stage)
avtar Info <7925>: Restored 0 bytes from selection(s) with 0 bytes in 0 files

La conexión en el DDR no es posible desde estas líneas.

Se confirmó que puede conectar los diferentes puertos de DPSearch a Data Domain mediante telnet. Como Telnet no está instalado de forma predeterminada en la máquina, instálelo manualmente siguiendo estos pasos: 

  1. Descargue los dos archivos en el archivo adjunto de este artículo y colóquelos en /tmp desde la máquina DPSearch mediante WinSCP, por ejemplo.
  2. Ejecute lo siguiente:
rpm --install telnet-server-1.2-165.63.x86_64.rpm
rpm --install telnet-1.2-165.63.x86_64.rpm
  1. Una vez instalado, ejecute la siguiente consulta para probar los puertos:
telnet DDomainHostnameOrIP 111
telnet DDomainHostnameOrIP 2049
telnet DDomainHostnameOrIP 2052

El resultado de telnet del puerto 111 falla:

dpsearch:/ # telnet DataDomainIP 111 Trying DataDomainIP... telnet: connect to address DataDomainIP: Connection timed out

Causa

Este problema se debe a que el puerto 111 (DDBoost/Portmapper) entre Data Domain y DPSearch no está abierto.

Este puerto debe estar abierto porque, durante el proceso de recopilación, los respaldos se restauran y deben poder obtener el archivo zMetadata.sql en DPSearch para enumerar todos los datos del respaldo. Dado que el puerto no está abierto, este proceso no es posible y se produce un error acerca de No es posible iniciar sesión en DDR.

En los siguientes artículos de Data Domain, se explica el uso de puertos de Data Domain:

Resolución

Abra el puerto 111 para permitir la comunicación entre Data Domain y DPSearch.

Una vez hecho esto, ejecute el comando telnet nuevamente:
telnet DDomainHostnameOrIP 111

Productos afectados

Data Protection Search

Productos

Data Protection Search
Propiedades del artículo
Número del artículo: 000192416
Tipo de artículo: Solution
Última modificación: 23 mar 2026
Versión:  2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.