Connectrix Brocade serie B: SANnav, los soportes de switch y las descargas de firmware iniciadas por SANnav fallan

Resumen: Cuando se intenta recolectar un supportsave o ejecutar una descarga de firmware mediante SANnav, la acción falla rápidamente. El inicio de supportsave/firmware descargado manualmente por la CLI y apúntelo al mismo servidor SFTP de SANnav funciona sin problemas. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Impacto:
No se puede iniciar el supportsave del switch desde SANnav.
No se puede iniciar la descarga de firmware desde SANnav.

Medio ambiente:
Software Brocade: Fabric OS 8.2.2c
Software Brocade: Fabric OS 9.0.1b

Problema:
Cuando se intenta recolectar un supportsave o ejecutar una descarga de firmware mediante SANnav, la acción falla rápidamente.
Iniciar supportsave o firmware download manualmente mediante la CLI y apuntarlo al mismo servidor SFTP de SANnav funciona sin problemas.

El errdump del switch puede contener el siguiente error:
Ejemplo:

[SS-1001], 179, CHASSIS, WARNING, sw0, supportSave's upload operation to remote host has been aborted (Error occurred in SSH).

Los registros de SANnav muestran los siguientes eventos:

Failed to generate Supportsave for switch 10.0.0.1. Reason: SupportSave - Invalid config options.

 

Causa

Hay un DEFECTO en Fabric OS que impide que FOS maneje contraseñas con ciertos caracteres especiales, como $.
Si la contraseña de SANnav SFTP o SCP está configurada para incluir el carácter $, esto provoca supportsaves y firmwaredownloads iniciado por SANnav para fallar.

Brocado DEFECTO FOS-820674

 

Resolución

ARREGLAR:
Actualice a Fabric OS 8.2.2d o superior.
Actualice a Fabric OS 8.2.3 o superior.
Actualice a Fabric OS 9.0.1c o superior.

Solución alternativa:
Hay dos opciones:

  1. Ejecutar supportsave/firmwaredownload mediante la CLI desde el switch en lugar de SANnav, apuntándolo a SANnav o a un servidor SFTP alternativo.

O

  1. Cambie la contraseña de SFTP de SANnav para que no incluya el símbolo $ en la contraseña.

    En la versión 2.1.1 y anteriores, SANnav se debe desinstalar y volver a instalar para cambiar la contraseña de SFTP.

 

Información adicional

Artículo de Brocade SLN 14544
Consulte el siguiente artículo de la base de conocimientos compuesto principalmente sobre el proceso de descargas de FOS.
Connectrix: Cómo acceder a Brocade FOS para switches Dell heredados y serie B mediante la autoayuda

 

Productos afectados

Connectrix B-Series Software, Connectrix SANnav
Propiedades del artículo
Número del artículo: 000198284
Tipo de artículo: Solution
Última modificación: 13 may 2026
Versión:  11
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.