Dell Unity: Después de la actualización, se observa el mensaje de advertencia "No se cumple la política de hot spare para el pool tradicional". (Corregible por el usuario)

Resumen: Después de actualizar el código 5.2.1.0.5.013 o superior, Unisphere informa un mensaje de advertencia sobre la política de unidades de repuesto.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Después de actualizar el código de OE del arreglo, Unisphere informa un mensaje de advertencia con respecto a la política de hot spare.

Mensaje de advertencia de la política de repuesto dinámico

En Data Collects, puede ver instancias de la infracción que se denuncian:

TRiiAGE_full_ECOM.txt:

A       10/26/24 19:03:20.000 isSparePolicyViolated     cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]
A       10/28/24 17:51:26.000 isSparePolicyViolated     cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]

TRiiAGE_full_SPlogs.txt:

B       10/19/24 02:14:26.981 CoreProvisionSvc   5200a6 [ERROR] Audit: The spare drive policy for traditional pools is not being met. Add a minimum of 1 1.8 TB SAS 10K drives to the system.
B       10/21/24 17:42:11.020 CoreProvisionSvc   5200a7 [INFO] Audit: The system has 1.8 TB SAS 10K drives, which is enough to meet the spare drive policy for traditional pools.

SPx/EMC/CEM/log/cemtracer.log:

A 10/26/24 07:36:39.000 isSparePolicyViolated cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]
A 10/28/24 08:07:03.000 isSparePolicyViolated cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]

SPx\EMC\CEM\log\cemtracer_health_services.log:

03 Nov 2024 12:22:34  - [Health] INFO - {0:672637:49317478}[21732|4329|e5fffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.
03 Nov 2024 12:23:34  - [Health] INFO - {0:672696:799062102}[21732|4329|e5fffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.
03 Nov 2024 12:28:51  - [Health] INFO - {0:673013:665903359}[21732|718|e59ffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.
03 Nov 2024 12:28:51  - [Health] INFO - {0:673013:814940102}[21732|4329|e5fffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.

Causa

Los mensajes de advertencia informarán en el pool tradicional cuando no se cumpla la política de hot spare.  Según la política de hot spare, debe haber 1 unidad de repuesto por cada 31 unidades del mismo tipo, capacidad y velocidad de rotación o tipo flash.

En ciertos escenarios, se ha observado que el mensaje de advertencia no aparece hasta después de una actualización. En esas situaciones, fue una unidad del sistema (disco DPE 0 a disco DPE 3) la que falló en el pasado. No se permite que las unidades del sistema sean hot spare. Cuando una unidad del sistema falla y, luego, se reemplaza, el conteo de hot spare disminuirá en una unidad.

Resolución

En primer lugar, determine si hay unidades sin enlazar disponibles (sin incluir las unidades del sistema del disco DPE 0 al disco DPE 3):

  • En Unisphere, vaya a Ajustes Configuración >de almacenamiento>Unidades.
  • Busque en la columna "Unconfigured Available" para ver si hay unidades disponibles para el tipo de unidad específico.
  • Si hay unidades disponibles, intente reiniciar los servicios de administración.
  • Consulte el KBA 000019458 Dell Unity: Cómo reiniciar o conmutar por error los servicios de administración (corregible por el usuario)
  • Si hay unidades dentro de la columna "Disponible sin configurar" y reiniciar los servicios de administración no resuelve el mensaje de advertencia, comuníquese con el soporte de Unity para obtener más ayuda.

Revise el historial de fallas de unidad para determinar si una unidad del sistema (disco DPE 0 a disco DPE 3) falló en el pasado,

  • En la página Unidades de propiedades> del pool, verifique si alguna de las unidades del sistema forma parte del pool. Las primeras 4 unidades de cada sistema Dell Unity se denominan unidades del sistema (disco de DPE 0 a disco DPE 3). Dell Unity OE también utiliza la capacidad de estas 4 unidades para almacenar copias de información de configuración y otros datos cruciales del sistema.
  • Ejemplo: Los discos 0 a 2 del DPE forman parte de un pool, mientras que el disco 3 del DPE se muestra sin enlazar. Revise los reemplazos de discos anteriores para verificar si se reemplazó el disco 3 del DPE. 
    • Si la unidad del sistema falló en el pasado y aún se encuentra en un estado sin enlazar, existe la posibilidad de que esa sea la causa del mensaje de advertencia, ya que dejará corta la política de hot spare 1 unidad. 
    • Cuando una unidad del sistema falla, los datos de usuario se copian en un hot spare del mismo tipo.  Cuando se reemplaza esa unidad del sistema, el ambiente operativo no permitirá que la unidad del sistema se convierta en un hot spare. El sistema Unity no copiará automáticamente los datos de usuario en la unidad del sistema. A fin de recuperar una unidad de hot spare, será necesario recurrir al soporte de Unity para copiar manualmente los datos del usuario a la unidad del sistema.
  • Consulte Dell EMC Unity: Guía de prácticas recomendadas , página 17, sección 2.2.4 "Unidades del sistema" para obtener más detalles.
  • Si el problema coincide con el escenario de la unidad del sistema, hay 2 opciones para resolver el mensaje de advertencia.
    • Opción 1: Agregue más unidades al arreglo para permitir otro hot spare
    • Opción 2: Copie los datos de usuario del hot spare original a la nueva unidad del sistema. Si esta es la opción, comuníquese con el soporte y consulte este artículo de la base de conocimientos con su opción.

Productos afectados

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Propiedades del artículo
Número del artículo: 000207645
Tipo de artículo: Solution
Última modificación: 22 ene 2026
Versión:  9
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.