Avamar: Los registros de Avagent muestran "CR_ERROR" durante el registro o el respaldo

Resumen: Los registros de Avagent muestran el error "CR_ERROR"

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Situación 1: el registro del cliente falla:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

-- O --

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

Situación 2: se completa el registro, pero los respaldos se bloquean en "Esperando cliente" o "Fin de tiempo de espera agotado" sin transferencia de datos:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

-- O --

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Causa

Si la solicitud en avagent Informes de registro"No response to message" o "CR_ERROR Durante el protocolo de enlace inicial, hay un problema de comunicación que bloquea el send/ack entre la cuadrícula de Avamar y el cliente.

Nota: Todos los errores en ambas situaciones indican problemas relacionados con la red o el firewall en el entorno del cliente.

Resolución

Se pueden utilizar los siguientes pasos para ayudar a encontrar cuellos de botella:

1. Compruebe que todos los puertos Avamar necesarios estén abiertos en el firewall y que puedan enviar y recibir datos.
(Servidor Avamar a cliente y cliente a servidor Avamar)

2. Compruebe si hay algún antivirus o software de detección de malware que bloquee los datos en los puertos Avamar.

3. Si el cliente está detrás de una NAT, verifique que las tablas de enrutamiento estén configuradas correctamente.

4. Si se observa el mismo error en todos los clientes, asegúrese de que no se hayan realizado cambios en la red Avamar.

5. Comuníquese con el equipo de red para rastrear el tráfico de red desde el cliente fallido hasta la cuadrícula de Avamar y comprobar si hay pérdidas de paquetes en la red.

6. Si no se pueden encontrar problemas, recopile tcpdump y Wireshark o Netmon información y crear una solicitud de servicio.

Información adicional

Recursos de Wireshark:
 
Recursos de TCPDump:
  •    https://linuxtechlab.com/learn-use-tcpdump-command-examples(Enlace externo)

Productos afectados

Avamar, Avamar Client
Propiedades del artículo
Número del artículo: 000040936
Tipo de artículo: Solution
Última modificación: 24 sept 2025
Versión:  8
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.