DPA: Se devolvió el error 500 cuando se ejecutan informes

Resumen: Cuando se intenta ejecutar un informe de resumen de cliente o de trabajo, aparece una ventana emergente con un error 500. Los informes nunca se ejecutan

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Cuando se intenta ejecutar un informe de resumen de cliente o de trabajo, aparece una ventana emergente con un error 500. Los informes nunca se ejecutan

Al examinar los archivos de registro del servidor de la aplicación Data Protection Advisor (DPA), había muchos mensajes de advertencia que indicaban que no se podían insertar datos en tablas o que no se podían ejecutar consultas.
Por ejemplo:

Failed executing updatesql=insert into bkup_ddclone .......Caused by: java.sql.SQLException: Error

Y

Unhandled exception thrown from onMessage: java.lang.IllegalStateException: Failed processing agent report: BaseTransaction.rollback - ARJUNA016074: no transaction! ..........Caused by: com.emc.apollo.services.database.NativeQueryException: Failed executing querysql=select * from backupevent

Se observaron los siguientes errores al examinar los registros del almacén de datos de DPA:

"ERROR: could not extend file "pg_tblspc/16390/PG_9.6_201608131/16385/35561.12": No space left on device"
"ERROR: could not open file "pg_tblspc/16389/PG_9.6_201608131/16385/35570": No such file or directory".

Se observa otro mensaje de error en los registros del almacén de datos después de reiniciar un almacén de datos:

2019-08-07 13:22:26.172 EDT 11996 5d4b08d0.2edc 1 apollo:ERROR: could not open file "pg_tblspc/16389/PG_9.6_201608131/16385/35558.5" (target block 2322516): previous segment is only 13128 blocks

Al examinar el sistema de archivos del almacén de datos, se descubre que el sistema de archivos donde reside la base de datos (...\services\datastore\data) no tiene espacio.

 

Causa

La ventana emergente Error 500 es un error genérico de la aplicación DPA, que indica que no se pudo realizar la última acción o comando.

La causa de la incapacidad de ejecutar informes es que la base de datos no tiene espacio en disco.

Cuando el sistema de archivos se llena, pueden producirse varios problemas.

Si la interfaz de usuario de DPA ya se está ejecutando, se observa comportamiento incorrecto y fallas en varias áreas de la interfaz de usuario, incluidos los informes en ejecución. Esto se debe a que la aplicación DPA debe ser capaz de consultar la base de datos para obtener información y datos. Por lo general, esto no es posible cuando el sistema de archivos de la base de datos está lleno.

La base de datos podría corromperse o dañarse de alguna manera. Postgres almacena en caché cierta cantidad de datos en la memoria compartida en cualquier punto en el tiempo. Si el sistema de archivos se llena, Postgres no puede confirmar (escribir) estos datos en el sistema de archivos como debería. Esto puede hacer que se pierdan los datos que se iban a insertar. También puede hacer que los archivos de la base de datos estén incompletos y dañados. Por último, es posible que otros datos no se escriban como deberían, incluidos los archivos de control de la base de datos.

También es probable que el almacén de datos no se pueda reiniciar una vez que el sistema de archivos esté lleno.

 

Resolución

Requiere que se proporcione más espacio en el sistema de archivos (disco) a la base de datos del área de almacenamiento de datos para resolver este problema. Esto se puede hacer de varias maneras, incluida la extensión del sistema de archivos o la adición de un nuevo disco. Consulte con los administradores del servidor para obtener ayuda con la adición de espacio.

Nota: Existe un concepto erróneo común de que los datos simplemente se pueden eliminar de la base de datos del almacén de datos para recuperar espacio. A menudo, esto no es posible por algunas razones. Una razón es que no se puede iniciar el almacén de datos una vez que el sistema de archivos está lleno. Otra es que la eliminación de datos de una base de datos es un proceso complejo que requiere una investigación que requiere mucho tiempo sobre la naturaleza y la cantidad de datos en cualquier número de tablas. A menudo, esta no es una tarea que se pueda llevar a cabo a corto plazo.

Una vez que se agrega espacio de disco, se puede volver a iniciar la base de datos del almacén de datos.

Tras el reinicio, la base de datos intenta realizar una recuperación de la finalización anormal anterior. El inicio de la recuperación intenta hacer las correcciones posibles para que la base de datos funcione y esté en funcionamiento. Esto puede o no dar lugar a una base de datos normal y en funcionamiento. Podría dar lugar a una base de datos que parece funcionar normalmente, pero que tiene problemas o daños en la estructura interna. Además, como se mencionó anteriormente, es probable que resulte en cierta cantidad de pérdida de datos

Después de reiniciar la base de datos del almacén de datos, el soporte técnico de Dell debe examinar la base de datos para asegurarse de que funcione con normalidad y de que no haya otros efectos secundarios o problemas.

También se recomienda realizar una exportación del almacén de datos para garantizar que haya una copia viable de la base de datos disponible en el futuro. Preferiblemente, ejecute el comando de exportación con el modificador "--debug" agregado, para que proporcione una salida de depuración. Redirija este resultado a un archivo para que se pueda revisar posteriormente en busca de problemas.

Comuníquese con el soporte técnico de Dell para obtener más información y asistencia.

 

Productos afectados

Data Protection Advisor

Productos

Data Protection Advisor
Propiedades del artículo
Número del artículo: 000053744
Tipo de artículo: Solution
Última modificación: 06 nov 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.