SQL 伺服器型號資料庫修復

Resumen: SQL 伺服器型號資料庫修復

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

問題:
您處理之 Microsoft SQL Server 實例上的型號資料庫已損毀,SQL Server 服務也無法啟動。

Causa

Microsoft SQL Server 資料庫、記錄和應用程式檔案的軟體損毀

Resolución

Microsoft SQL Server 型號資料庫的說明,以及其作為 SQL Server 系統資料庫的用途。

修復:
在許多情況下,還原 SQL Server 資料庫可以補救資料庫損毀事件,並使一切恢復正常。機型資料庫損毀會造成問題,使其難以執行正常的還原作業。無法啟動 SQL Server 服務,使得在 SQL Server Studio Management 中執行一般 SQL Server 還原作業變得不可能。

若要將 SQL Server Model 資料庫連線至線上,最快速、最可靠的解決方案需要提供新的型號資料庫檔案複本,並重新啟動 SQL Server 服務。以下步驟可用於尋找和更換必要的 SQL 範本檔案,以便成功更換型號資料庫檔案,使 SQL Server 能夠順利啟動。

還原型號資料庫的步驟:

  1. 前往 Microsoft SQL Server 安裝中的 預設資料庫範本 儲存資料夾。預設位置是「C:\Program Files\Microsoft SQL Server\MSSQLxxSQLInstanceName\MSSQL\Binn\Templates」。此範例中的 SQL Server 實例名稱可能有所不同,但代表用來更換型號資料庫檔案的實例名稱。

在我們的範例中:
「C:\Program Files\Microsoft SQL Server\MSSQL14。SQLTEST\ MSSQL\Binn\Templates「 資料夾是我們基本預設型號資料庫檔案的位置。

Microsoft SQL Server Model Database 範本檔案的預設位置。
  1. 當我們找到 model.mdf 和 modellog.ldf 檔案時,請複製檔案並準備好貼到 SQL Server 實例的工作資料庫目錄中。
型號資料庫和記錄檔的預設檔案位置。
  1. 將複製的預設型號資料庫檔案貼到已安裝 SQL Server 的工作資料庫目錄中。在這種情況下,檔案路徑位置為「C:\Program Files\Microsoft SQL Server\MSSQL14SQLTEST\MSSQL\DATA」  
SQL Server Model 資料庫的預設作用中資料庫檔案位置。
  1. 找到我們在 SQL Server Configuration Manager 中進行故障診斷的 SQL Server 服務實例名稱。在這種情況下,它是 SQL Server (SQLTEST)。
在 Microsoft SQL Server Configuration Manager 中,SQL Server 服務的 SQL Server 實例所在位置。
  1. 啟動與 SQL Server 實例相關的服務,進行疑難排解。
啟動 SQL Server 服務。
  1. 如果模型資料庫已自訂為包含用於組織生產資料庫的常見資料庫專案和功能,則可能會執行模型資料庫良好備份的還原,以將這些專案和功能重新放回模型資料庫中。 
  2. SQL Server 的最新更新也應套用在這裡,以確保型號資料庫的版本與我們的其他系統資料庫相符。

Productos afectados

Dell Quickstart Data Warehouse Appliance, Prosupport for Microsoft Software
Propiedades del artículo
Número del artículo: 000134526
Tipo de artículo: Solution
Última modificación: 18 mar 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.