PowerProtect: Los respaldos pueden fallar con el mensaje "No se puede enviar la solicitud al host inaccesible mediante la dirección y el puerto 7000"

Resumen: En este artículo, se aborda un problema de falla de respaldo en PowerProtect Data Manager 19.14 con clientes que utilizan doble pila.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Es posible que se reciba el siguiente mensaje de error cuando los respaldos fallan cuando los clientes utilizan doble pila. El error se observa en los registros de ADM (/var/log/brs/adm/adm.log):

com.emc.dpsg.ecdm.adm.shared.exception.AdmException: Unable to send request to unreachable host 2196a9d9-3205-4507-81e0-d82d3a284f7a using address <ip_address> and port 7000

 

Se observa el siguiente error en los registros de AgentService desde el cliente de respaldo (DPSAPPS\AgentService\logs):

ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI1882\main.py-update_configs()-Line 249- error in updating configs: Error occurred while getting IP from FQDN: [Errno 11004] host not found.

 

NOTA: Este artículo solo se aplica a PowerProtect Data Manager 19.14. Este artículo NO se aplica a ninguna versión anterior a 19.14.

 

Causa

Se identifica un problema que puede ocurrir en entornos de doble pila (IPv4 o IPv6) en los que hay una incompatibilidad entre la dirección IP recomendada de PowerProtect Data Manager para el cliente de respaldo y el servicio de agente que se vincula a la dirección IP del cliente de respaldo.

 

Resolución

Solución:

  1. En los hosts de aplicaciones, compruebe la dirección de enlace del servicio de agente mediante el siguiente comando:

    • Linux o AIX:
      netstat -an | grep <7000|port number>
    • Windows:
      netstat -an | findstr <7000|port number>
  2. En el servidor de PowerProtect Data Manager, compruebe la resolución de la dirección preferida siguiendo la siguiente ruta:

    1. Vaya a la página >Application Agents y seleccione Host >More Actions>Set Preferred Address. Capture la dirección preferida.
    2. Utilice la dirección preferida del paso 2a y ejecute el comando:
      curl -kv http://<preferred address>:<port number>/greetings

    Si se produce una falla, vaya al paso 3.

  3. Si hay una falla en el paso 2, compruebe si hay una incompatibilidad en la dirección de la pila IP de los pasos 1 y 2.

    1. En la interfaz de usuario de PowerProtect Data Manager, seleccione el host de aplicaciones y cambie la dirección preferida para que coincida con la pila de IP en el paso 1.
      1. Vaya a la página >Application Agents, seleccione Host>, More Actions>, Set Preferred Address y cámbielo para que coincida con la pila IP del paso 1.
        O
    2. En el agente de aplicaciones, cambie la dirección de vinculación de los agentes para que coincida con la dirección preferida seleccionada por el usuario.
      1. Ejecute el instalador y elija como "Dirección de host de aplicaciones preferida para la comunicación" la dirección IP que se encuentra en el paso 2.

 

NOTA IMPORTANTE: Las resoluciones de nombres y las búsquedas inversas se deben configurar para garantizar lo siguiente:
  • Los FQDN de los hosts del agente de aplicaciones que utilizan FQDN como su dirección de host preferida se resuelven en una dirección IPv4 o IPv6 válida.
  • Cada host de agente de aplicaciones que utiliza FQDN como su dirección de host preferida resuelve el FQDN de PowerProtect Data Manager en una dirección IP del mismo protocolo que utiliza. Por ejemplo, si un host utiliza IPv4, resuelve el FQDN de PowerProtect Data Manager en una dirección IPv4.

 

Productos afectados

PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Propiedades del artículo
Número del artículo: 000215647
Tipo de artículo: Solution
Última modificación: 15 abr 2024
Versión:  3
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