SQL Server-service (MSSQLSERVER) Kan niet worden gestart
Resumen: De Microsoft SQL Server-service (MSSQLSERVER) kan mogelijk niet worden gestart vanwege een beschadigde database. Dit artikel illustreert de procedure voor het oplossen van dit probleem. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
De Microsoft SQL Server-service (MSSQLSERVER) kan niet worden gestart. Fout 7024 (bron: Service Control Manager) wordt weergegeven in het systeemgebeurtenislogboek van de server waarop SQL is geïnstalleerd.
Causa
Deze service kan om meerdere redenen niet worden gestart, en dit artikel behandelt er één: een beschadigde database.
Resolución
Wanneer een service niet wordt gestart, registreert de Service Control Manager een fout in het systeemgebeurtenislogboek van de server die als host voor die service fungeert. Deze gebeurtenis (in dit geval ID 7024) biedt mogelijk onvoldoende details om het probleem op te lossen. Bij het oplossen van een probleem met de SQL Server-service bevat het SQL-foutenlogboek waarschijnlijk meer nuttige informatie.
Volg deze stappen om het SQL-foutenlogboek te vinden:
Een beschadigde database kan worden aangegeven door een fout die lijkt op deze:
SQL Server heeft een op logische consistentie gebaseerde I/O-fout gedetecteerd: Onjuiste checksum
De foutmelding geeft ook aan in welke database het probleem is voorgekomen. Er zijn drie systeemdatabases vereist voor het starten van SQL-services: de hoofddatabase, de modeldatabase en tempdb. De fout vermeldt hoogstwaarschijnlijk een van deze databases.
Als beschadiging in de hoofddatabase de oorzaak is, is het herstellen van die database vanaf een back-up de aanbevolen oplossing.
Als beschadiging in de modeldatabase de oorzaak is, kan een reparatieprocedure worden gevonden in SQL Server Model Database Repair.
Telkens wanneer de SQL Server-service wordt gestart, wordt de tempdb-database opnieuw gemaakt, zolang de modeldatabase intact is.
Volg deze stappen om het SQL-foutenlogboek te vinden:
- Start SQL Server Configuration Manager.
- Selecteer SQL Server Services in het linkerdeelvenster.
- Klik in het middelste deelvenster met de rechtermuisknop op SQL Server (MSSQLSERVER) en selecteer Eigenschappen.
- Selecteer in het venster Eigenschappen het tabblad Opstartparameters .
- In het veld Bestaande parameters bevat de vermelding die begint met -e het pad naar het foutenlogboek.
Een beschadigde database kan worden aangegeven door een fout die lijkt op deze:
SQL Server heeft een op logische consistentie gebaseerde I/O-fout gedetecteerd: Onjuiste checksum
De foutmelding geeft ook aan in welke database het probleem is voorgekomen. Er zijn drie systeemdatabases vereist voor het starten van SQL-services: de hoofddatabase, de modeldatabase en tempdb. De fout vermeldt hoogstwaarschijnlijk een van deze databases.
Als beschadiging in de hoofddatabase de oorzaak is, is het herstellen van die database vanaf een back-up de aanbevolen oplossing.
Als beschadiging in de modeldatabase de oorzaak is, kan een reparatieprocedure worden gevonden in SQL Server Model Database Repair.
Telkens wanneer de SQL Server-service wordt gestart, wordt de tempdb-database opnieuw gemaakt, zolang de modeldatabase intact is.
Productos afectados
Prosupport for Microsoft SoftwarePropiedades del artículo
Número del artículo: 000223030
Tipo de artículo: Solution
Última modificación: 23 ene 2025
Versión: 3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.