Data Protection Advisor 6.4: El servidor de aplicaciones de DPA deja de responder o falla periódicamente

Resumen: En este artículo, se explica la solución cuando un servidor de la aplicación de DPA deja de responder o falla periódicamente.

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Síntomas

El servidor de la aplicación de DPA deja de responder o falla periódicamente.

Al revisar el archivo executive.log en la carpeta dpa/services/logs en el servidor de la aplicación, encontrará que el sistema está haciendo ping a la JVM con tiempos de respuesta de más de 200 segundos con entradas de registro como las siguientes:

2017/07/12 01:46:26.718 | Pinging the JVM took 284 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 280 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 276 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 272 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 267 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 263 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 259 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 255 seconds to respond.
2017/07/12 01:46:26.718 | Pinging the JVM took 251 seconds to respond.

También puede ver errores de memoria en este registro, como los siguientes:

2017/07/13 07:56:32.113 | Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "TxCleanupService,analysispolicycache,local"
2017/07/13 07:56:32.113 | Filter trigger matched.  Restarting JVM.

 

Causa

La máquina virtual Java en la que se ejecuta DPA se quedó sin memoria y el sistema dejó de responder o falló.

 

Resolución

En primer lugar, detenga los servicios de la aplicación y, si es posible, reinicie el servidor, ya que esto borra la memoria y permite que el servidor inicie el respaldo nuevamente.

Varios problemas causan este problema. Normalmente, esto se debe a informes que tienen un gran origen de datos, alcance o período de tiempo que no pueden procesarse con la memoria disponible para DPA.

Revise los informes programados. Si tiene más de 10 informes programados a la vez, divídalos para que no se ejecuten más de 10 a la vez, mantenga intervalos de 15 minutos entre ellos.

Si utiliza el agente de la aplicación DPA para la recolección de datos, considere mover esa recopilación a otro agente, ya que los agentes utilizan la memoria para realizar la recolección de datos y eso puede limitar la memoria disponible para la aplicación.

Si esto sucede con frecuencia, se requiere agregar memoria al servidor DPA para resolver este problema. Una vez que haya agregado memoria, debe ajustar DPA para esa memoria, por lo que, desde un símbolo del sistema de administrador o como raíz, navegue hasta <DPA install directory>/dpa/services/bin y ejecute el siguiente comando:
dpa app tune 16GB (donde 16 GB es la cantidad de memoria en el sistema, por lo que esto sería para un servidor de 16 GB).

A continuación, reinicie el servicio DPA APP.

Comuníquese con el soporte técnico de Dell Technologies para obtener más detalles o información.

 

Productos

Data Protection Advisor
Propiedades del artículo
Número del artículo: 000056975
Tipo de artículo: Solution
Última modificación: 17 abr 2026
Versión:  6
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