XtremIO: Jak vyřešit chybu „obj_identifier_not_unique“

Resumen: Jak vyřešit chybu „obj_identifier_not_unique“.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Při pokusu o vytvoření snapshotu může systém XMS zobrazit chybový kód „obj_identifier_not_unique“. Příklad je uveden níže.
 
create-snapshot consistency-group-id="CG_name1" snapshot-set-name="SS_name1" snap-suffix="DB"
*** XMS Completion Code: obj_identifier_not_unique

Causa

Vytvářený objekt se pokoušel použít stejný identifikátor, jaký má stávající objekt, například číslo indexu nebo název.

Výše uvedený příklad ukazuje vytváření snapshotu pro skupinu konzistence. V tomto příkladu kontrola objektů v systému XMS zjistila, že vytvářený snapshot se pokouší vytvořit snapshot, který by měl stejný název jako jiný snapshot, který v poli již existuje.

Chcete-li ověřit, zda je to způsobeno již používaným názvem svazku, proveďte následující kroky:
  1. Poznamenejte si názvy svazků ve skupině konzistence nebo sadě snapshotů, ze kterých vytváříte snapshot.
  2. Poznamenejte si název přípony snapshotu, protože vlastní názvy přípon obvykle vedou k tomuto problému.
  3. Přihlaste se do pole pomocí rozhraní XMCLI, spusťte příkaz show-volumes a zkopírujte výstup do textového dokumentu. Vyhledejte názvy svazků ze skupiny CG nebo SS, pro které vytváříte snapshot.
U verzí 6.x XMS je další možností použít filtr k vyhledání konkrétních názvů svazků (například: show-volumes filter=Volume-Name:like:test. Tím se vrátí všechny svazky a snapshoty s názvem obsahujícím řetězec „test“).
  1. Zkontrolujte výsledky hledání. Pokud by použití zamýšlené přípony u jakýchkoli svazků ve skupině CG nebo SS vytvořilo snapshot, který odpovídá jinému svazku nebo snapshotu, který se nachází v poli, jedná se o příčinu (nebo jednu z příčin) této chyby.
Další metodou ověření je také změna přípony snapshotu na něco, co není v poli přítomno.

Resolución

Existují dvě řešení:
  1. Nejjednodušší možností je zvolit jinou příponu, která se nepoužívá nikde jinde v clusteru. To může být také rychlý způsob, jak zjistit, zda je problém přítomen.
  2. Pokud byl identifikován název svazku způsobující problém, přejmenujte svazek, ze kterého má být snapshot vytvořen, nebo jiný svazek nebo snapshot, který v poli existuje, na jiný název.
Pokud nebyly identifikovány žádné svazky, které by vedly k vytvoření duplicitního názvu, obraťte se na globální technickou podporu společnosti Dell EMC, odkažte se na tento článek znalostní databáze a uveďte podrobnosti o provedené operaci a chybě. Pro rozhraní XMCLI by měl být poskytnut úplný příkaz. V uživatelském rozhraní zadejte název CG nebo SS a příponu. 

Información adicional

Při pokusu o provedení této operace v uživatelském rozhraní mohou některé verze uživatelského rozhraní zobrazit zprávu „Suffix creates existing names on CLUSTER_NAME“ při pokusu o nastavení přípony na název, který by vytvořil duplicitní názvy.

Productos afectados

XtremIO Family

Productos

XtremIO Family, XtremIO HW Gen2 400GB, XtremIO HW Gen2 400GB Encrypt Capbl, XtremIO HW Gen2 400GB Encrypt Disable, XtremIO HW Gen2 400GB Exp Encrypt Disable, XtremIO HW Gen2 400GB Expandable, XtremIO HW Gen2 800GB Encrypt Capbl , XtremIO HW Gen2 800GB Encrypt Disable, XtremIO HW Gen3 40TB, XtremIO HW Gen3 40TB Encrypt Disable, XtremIO HW X2-R, XtremIO HW X2-R Encrypt Disable, XtremIO HW X2-S, XtremIO HW X2-S Encrypt Disable, XtremIO HW X2-T, XtremIO HW X2-T Encrypt Disable, XtremIO X1, XtremIO X2 ...
Propiedades del artículo
Número del artículo: 000071475
Tipo de artículo: Solution
Última modificación: 05 sept 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.