XtremIO. Как устранить ошибку «obj_identifier_not_unique»

Resumen: Как устранить ошибку «obj_identifier_not_unique».

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

При попытке создать моментальный снимок XMS может выдавать код ошибки «obj_identifier_not_unique». Пример показан ниже.
 
create-snapshot consistency-group-id="CG_name1" snapshot-set-name="SS_name1" snap-suffix="DB"
*** XMS Completion Code: obj_identifier_not_unique

Causa

Создаваемый объект пытался использовать тот же идентификатор, что и существующий объект, например порядковый номер или имя.

В приведенном выше примере показан моментальный снимок, созданный для группы консистентности. В данном примере при просмотре объектов в XMS обнаружено, что создаваемый моментальный снимок пытается создать снимок с именем, дублирующем имя снимка, уже существующего в дисковом массиве.

Чтобы проверить, связано ли это с именем тома, которое уже используется, выполните описанные ниже действия.
  1. Запишите имена томов в группе консистентности или наборе моментальных снимков, из которых создается моментальный снимок.
  2. Обратите внимание на имя суффикса моментального снимка, так как пользовательские имена суффиксов обычно приводят к этой проблеме.
  3. Войдите в массив с помощью XMCLI, выполните show-volumes и скопируйте выходные данные в текстовый документ. Найдите имена томов из группы консистентности или набора моментальных снимков, для которых создается моментальный снимок.
Альтернативный вариант для версий XMS 6.x: применить фильтр для поиска конкретных имен томов (например, show-volumes filter=Volume-Name:like:test. Это приведет к возврату всех томов и моментальных снимков с именем, содержащим строку «test»).
  1. Просмотрите результаты поиска. Если применить нужный суффикс к любым томам в группе консистентности или наборе моментальных снимков, то будет создан моментальный снимок, соответствующий другому тому или моментальному снимку, присутствующему в дисковом массиве — это является причиной (или одной из причин) возникновения ошибки.
Кроме того, другим методом проверки является изменение суффикса моментального снимка, который будет применяться к элементу, не присутствующему в дисковом массиве.

Resolución

Для устранения этой проблемы существует два варианта:
  1. Самый простой вариант — выбрать другой суффикс, который не используется ни для одного элемента в кластере. Это также может быть быстрым способом определить наличие проблемы.
  2. Если имя тома, вызывающее проблему, определено, переименуйте том, из которого должен быть создан моментальный снимок, или другой том или моментальный снимок, существующий в дисковом массиве.
Если тома не определены как ведущие к созданию дублирующегося имени, обратитесь в глобальную службу технической поддержки Dell EMC и укажите эту статью базы знаний, а также сведения о выполняемой операции и ошибке. Для XMCLI должна быть предоставлена полная команда. В пользовательском интерфейсе укажите имя группы консистентности или набора моментальных снимков и суффикс. 

Información adicional

При попытке выполнить эту операцию в некоторых версиях пользовательского интерфейса может отображаться сообщение «Suffix creates existing names on CLUSTER_NAME», если для суффикса будет установлено имя, дублирующее одно из уже имеющихся.

Productos afectados

XtremIO Family

Productos

XtremIO Family, XtremIO HW Gen2 400GB, XtremIO HW Gen2 400GB Encrypt Capbl, XtremIO HW Gen2 400GB Encrypt Disable, XtremIO HW Gen2 400GB Exp Encrypt Disable, XtremIO HW Gen2 400GB Expandable, XtremIO HW Gen2 800GB Encrypt Capbl , XtremIO HW Gen2 800GB Encrypt Disable, XtremIO HW Gen3 40TB, XtremIO HW Gen3 40TB Encrypt Disable, XtremIO HW X2-R, XtremIO HW X2-R Encrypt Disable, XtremIO HW X2-S, XtremIO HW X2-S Encrypt Disable, XtremIO HW X2-T, XtremIO HW X2-T Encrypt Disable, XtremIO X1, XtremIO X2 ...
Propiedades del artículo
Número del artículo: 000071475
Tipo de artículo: Solution
Última modificación: 05 sept 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.