CloudLink: Помилка "Не вдається отримати запитаний сертифікат"

Resumen: У vCenter під час спроби встановити довіру до CloudLink з'являється повідомлення про помилку «Неможливо отримати запитаний сертифікат».

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

У vCenter не вдалося встановити довіру до CloudLink під час початкового налаштування постачальника ключів.

Отримайте повідомлення про помилку, як показано нижче:
Cannot retrieve the requested certificate
 
Скріншот повідомлення про помилку

Causa

Однією з причин цієї помилки є те, що vCenter не може зв'язатися з CloudLink через порт 5696.

Ще одна потенційна причина полягає в тому, що користувач використовує версії CloudLink і vCenter, які несумісні.

Resolución

  1. SSH у базову систему vCenter
  2. Виконайте такі команди:
ping cloudlinkip
curl -v telnet://cloudlinkip:5696
curl -v --local-port 10000 telnet://cloudlinkip:5696
curl -v --local-port 20000 telnet://cloudlinkip:5696
curl -v --local-port 30000 telnet://cloudlinkip:5696
curl -v --local-port 40000 telnet://cloudlinkip:5696
curl -v --local-port 50000 telnet://cloudlinkip:5696
curl -v --local-port 60000 telnet://cloudlinkip:5696
  1. Якщо команди ping або curl не працюють, це може вказувати на проблему з брандмауером або мережею. Користувач повинен звернутися до мережевої команди та переконатися, що необхідні порти відкриті, а також переконатися, що віртуальні машини CloudLink знаходяться в правильній мережі або VLAN.
  2. Якщо команди curl виконані успішно, буде отримано повідомлення «Connected to x.x.x.x», як показано на цьому знімку екрана:
Скріншот успішного підключення
  1. Якщо команди ping і curl або telnet виконані успішно, перевірте сумісність версій CloudLink і vCenter. Може з'явитися повідомлення про помилку Не вдається отримати запитаний сертифікат, якщо використовується vCenter 8.x із CloudLink 7.1.7 або ранішої версії. Перегляньте Посібник із Це гіперпосилання спрямовує вас на веб-сайт за межами Dell Technologies.сумісності VMware для підтримуваних версій vCenter і CloudLink
CloudLink 7.0 підтримується vCenter 6.x і 7.x.
CloudLink 7.1.x підтримується з vCenter 6.x і 7.x.
CloudLink 8.x підтримується vCenter 7.x і 8.x.

CloudLink 8.x — це версія, яка офіційно підтримується з vCenter 8.x, однак CloudLink 7.1.8 і 7.1.9, схоже, працюють із vCenter 8.x.
  1. Оновлення CloudLink до 7.1.8, 7.1.9 або 8.x має вирішити проблему та забезпечити довіру.
 
Застереження: Якщо користувач використовує PowerFlex, він може бути не в змозі оновити CloudLink до певних версій. Вони повинні залишатися у версії CloudLink, зазначеній у їхньому RCM.

Productos afectados

CloudLink
Propiedades del artículo
Número del artículo: 000223969
Tipo de artículo: Solution
Última modificación: 13 nov 2025
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.