PowerStore: Evaluación del estado: El nodo de detección tiene una asignación de losas por encima del límite de skbuff_fclone_cache

Resumen: Estas comprobaciones están diseñadas para detectar si algún nodo tiene una asignación de SLAB superior al límite de skbuff_fclone_cache. La evaluación del estado previa a la actualización (PUHC, por sus siglas en inglés) "off_release_check_kernel_slab_memory_failed" detiene la actualización en un clúster que ejecuta PowerStoreOS 3.x y 4.0.x si detecta este problema. La "kernel_slab_check" de la evaluación del estado del sistema (SHC) falla si este problema se detecta en un clúster que ejecuta PowerStoreOS 3.x y 4.0.x. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

La evaluación del estado previa a la actualización (PUHC) y la evaluación del estado del sistema (SHC) de PowerStore pueden detectar este problema cuando se ejecutan en las siguientes versiones de PowerStoreOS:

  • PowerStoreOS 3.x
  • PowerStoreOS 4.0.x
NOTAR
El problema detectado por estas comprobaciones se resuelve en las versiones 4.0.1.2 (o superior) y 3.6.1.5 (o versiones 3.6.x superiores) de PowerStoreOS.
  • Por lo tanto, esta PUHC está configurada para detectar este problema solo cuando se actualiza desde las versiones 3.0.0 a 3.6.1.4 y desde las versiones 4.0.0 a 4.0.1.1.


Escenario 1:
Se puede observar el siguiente mensaje antes de una actualización de las versiones 3.0.0 a 3.6.1.4 de PowerStoreOS y delas versiones 4.0.0 a 4.0.1.1 cuando se ejecuta PUHC:

The available system memory or skbuff_fclone_cache is below threshold (KB 000261124). Please contact your service provider. (off_release_check_kernel_slab_memory_failed)

Apagado Comprobación de liberación Memoria de losa de kernel Comprobación de PUHC fallida

Escenario 2:
Es posible que se observe el siguiente mensaje en un clúster de PowerStoreOS 3.x o 4.0.x cuando se ejecuta SHC:

Kernel memory allocation is over the limit. (KB 000261124)

 Si la caché fclone de skbuff alcanzó su límite 

  • Si la prueba de evaluación del estado del sistema (SHC) se ejecuta desde la interfaz de línea de comandos (CLI), es posible que se muestre lo siguiente:
[BSC:cyc@ABCDEFG-A cyc]$ svc_health_check run -rhc kernel_slab_check
/usr/lib/python2.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.26.18) or chardet (3.0.4) doesn't match a supported version!
  RequestsDependencyWarning)
Name                               Location  Status     Description
OS kernel memory allocation check  node_a    Failed     Kernel memory allocation is over the limit. (KB 000261124)
OS kernel memory allocation check  node_b    Passed


SUMMARY Status: Failed
   Passed:      1
   Failed:      1
   Total:       2
[BSC:cyc@ABCDEFG-A cyc]$

 
[BSC:cyc@ABCDEFG-B ~]$ svc_health_check run -rhc kernel_slab_check
/usr/lib/python2.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.26.18) or chardet (3.0.4) doesn't match a supported version!
  RequestsDependencyWarning)
Name                               Location  Status     Description
OS kernel memory allocation check  node_a    Failed     Kernel memory allocation is over the limit. (KB#000261124)
OS kernel memory allocation check  node_b    Passed


SUMMARY Status: Failed
   Passed:      1
   Failed:      1
   Total:       2

 

Los resultados pueden variar según el nodo en el que falló la comprobación.

Estas evaluaciones del estado son comprobaciones de PUHC y SHC fuera de versión que se incluyen en el paquete delgado de evaluación del estado. Este paquete se puede descargar desde el sitio Controladores y descargas de Dell .

Consulte la sección Información adicional para obtener información sobre el paquete delgado de evaluación del estado.

Causa

Un nodo puede experimentar un kernel panic debido a una condición de falta de memoria (OOM). Este problema se debe al alto consumo de memoria de skbuff_fclone_cache de SLAB.

Resolución

Para resolver este problema, comuníquese con el soporte técnico de Dell para obtener ayuda. Mencione este artículo para obtener una rápida atención y resolución.

Información adicional

Productos afectados

PowerStoreOS
Propiedades del artículo
Número del artículo: 000261124
Tipo de artículo: Solution
Última modificación: 27 oct 2025
Versión:  10
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.