NetWorker: no se puede crear el cliente en NMC "no se puede determinar el nombre de la dirección 'null'"
Resumen: No se puede crear un cliente mediante el asistente New Client en NMC.
Síntomas
Aparece el siguiente mensaje mientras se intenta crear un nuevo cliente en NetWorker Management Console (NMC):
Connecting to host client_name failed: The host reports: Unable to create a session channel with nsrexecd on host client_name to execute the command ‘nsrfsra’: Unable to determine the name of address ‘null’ — Hostname.
Causa
nsrexecd_nsrfa Proporciona la funcionalidad de acceso remoto a archivos utilizada por NetWorker Server cuando necesita comunicarse con un cliente para operaciones relacionadas con la recuperación de archivos y metadatos en RPC.
No se puede crear el canal para el acceso remoto a archivos mediante nsrexecd .
Razones posibles:
- DNS incorrecto/búsqueda inversa
- El servicio nsrexecd del cliente no está en ejecución
- Incompatibilidad de rango de puertos
Además, si el archivo servers en la resolución tiene una entrada incorrecta:
- Corrupto,
- Contiene un nombre de servidor antiguo,
- Contiene entradas duplicadas,
- Tiene entradas de nombre de host/DNS incorrectas en el archivo de servidores.
- El formato de archivo del servidor está dañado
Resolución
Para solucionar este error, se deben realizar las siguientes comprobaciones y acciones:
- Verificar la resolución de nombres y la comunicación
- Asegúrese de que la resolución de nombres funcione correctamente en ambas direcciones: Server → Client y Client → Server mediante '
nslookup', y confirme que cada nombre de host se resuelva correctamente - Valide los puertos necesarios: Confirme que los puertos de servicio obligatorios de NetWorker 7937 y 7938 sean accesibles entre el servidor y el cliente.
- Asegúrese de que la resolución de nombres funcione correctamente en ambas direcciones: Server → Client y Client → Server mediante '
Desde el servidor de NetWorker y el cliente de NetWorker, utilice el comando nsrports Comando para validar la resolución de nombres y la comunicación de los puertos 7937 y 7938:
nsrports -t HOSTNAME -p PORT
Ejemplo del mensaje de salida:
[root@nsr ~]# nsrports -t rhel-client01.amer.lan -p 7937 Forward lookup for rhel-client01.amer.lan Query time: 0.001 sec Canonical name (CNAME): rhel-client01.amer.lan Address (A): 192.168.9.121 Connect to port 7937: Succeeded (0.001 sec) Reverse lookup for 192.168.9.121 Query time: 0.001 sec Name: rhel-client01.amer.lan
Para obtener más información, consulte: NetWorker: Cómo utilizar el comando nsrports
- Valide que NetWorker Server pueda ver
nsrexecd_nsrfaen el cliente de NetWorker:
nsrrpcinfo -p CLIENT_NAME
[root@nsr ~]# nsrrpcinfo -p rhel-client01.amer.lan PROGRAM VERSION PROTOCOL PORT SERVICE 100000 2 tcp 7938 nsrportmapper Port Mapper 100000 2 udp 7938 nsrportmapper Port Mapper 390436 1 tcp 8359 nsrexecd GSS Authentication 390435 1 tcp 9613 nsrexecd Resource Mirror 390113 1 tcp 7937 nsrexecd Remote Execution 390440 1 tcp 8942 nsrexecd_nsrfa Remote File Access
- Si el servidor no puede ver nsrexecd o nsrexecd_nsrfa en el cliente, realice las siguientes acciones en el sistema cliente:
- Valide que el servicio de cliente esté en ejecución:
- Linux:
ps -ef | grep nsr - Windows:
sc query nsrexecd
- Si el cliente no está en ejecución, intente iniciar los servicios:
- Linux:
systemctl start networker - Windows:
net start nsrexecd
daemon.raw Para errores en caso de que el servicio no se inicie:
- Linux:
/nsr/logs/daemon.raw - Windows (valor predeterminado):
C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw - NetWorker: Cómo usar nsr_render_log para representar .raw archivos de registro
- Si los servicios de cliente están en ejecución, compruebe si el
nsrexecd_nsrfase está ejecutando.
- Si el cliente tiene instalado el software "cliente extendido", puede comprobarlo con
nsrrpcinfo -p localhost. Este comando debe mostrar ambosnsrexecdynsrexecd_nsrfacorriendo. La variablensrrpcinfoEl comando no está disponible en sistemas que solo tienen instalado el paquete de cliente estándar. - Si el cliente no tiene instalado el software de cliente extendido, solo verá
nsrexecdsi se ejecuta con comandos del sistema operativo, no veránsrexecd_nsrfa. Debe validar desde NetWorker Server si puede vernsrexecd_nsrfaEscuchar al cliente (consulte el paso 2).
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- Compruebe el rango de puertos de NetWorker que se utiliza en el cliente mediante
nsrportscomando. El rango de puertos predeterminado es 7937-9936. Consulte: NetWorker: Cómo utilizar "nsrports -s" para cambiar el rango de puertos de servicio de NetWorker
- Compruebe el rango de puertos de NetWorker que se utiliza en el cliente mediante
- Compruebe si el cliente tiene un archivo "servers" en su carpeta "res":
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- Linux:
/nsr/res - Windows (valor predeterminado):
C:\Program Files\EMC NetWorker\nsr\res
- Linux:
-
- Si existe un archivo servers, se debe especificar una de las siguientes opciones:
-
- Debe estar vacío (se permiten todos los servidores)
- Si los servidores están definidos en el archivo, el servidor NetWorker Server desde el cual intentó agregar este cliente debe estar definido en el archivo.
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- Si no hay problemas obvios con el archivo, es posible que se haya dañado. Cambie el nombre del archivo y reinicie los servicios:
-
- Linux:
systemctl restart networker - Windows:
net stop nsrexecd && net start nsrexecd
- Linux:
Después de realizar todos los pasos de validación anteriores, intente agregar el cliente a NetWorker Server.