NVP-vProxy: El respaldo de VM falla para ciertas VM con un error de tiempo de ejecución "índice fuera de rango"

Resumen: Los respaldos de NetWorker VMware Protection (NVP) fallan para ciertas máquinas virtuales (VM). El error informado es "índice fuera de rango", lo que indica un problema de procesamiento interno o manejo de metadatos que afecta solo a VM específicas. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

La integración de NetWorker VMware Protection (NVP) está configurada con el dispositivo vProxy.
Los respaldos fallan para ciertas máquinas virtuales (VM) con un mensaje de índice de error de tiempo de ejecución fuera de rango.  
El registro de la sesión de respaldo muestra lo siguiente:

YYYY/MM/DD HH:MM:SS PANIC:  [145] Internal error occured, see log file: runtime error: index out of range.
YYYY/MM/DD HH:MM:SS PANIC:  [145] goroutine 13 [running]:
...
YYYY/MM/DD HH:MM:SS PANIC:  [145] vim.(*VimVirtualMachine).readCustomField(0xc8202f2800, 0x570500, 0x12, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, ...)
...
YYYY/MM/DD HH:MM:SS ERROR:  [145] Backup has FAILED.

Los registros de la sesión de respaldo de VM están disponibles en NetWorker Server en la siguiente ubicación:

  • Linux: /nsr/logs/polic/POLICY_NAME/WORKFLOW_NAME
  • Windows (valor predeterminado): C:\Program Files\EMC NetWorker\nsr\logs\POLICY_NAME\WORKFLOW_NAME

Los registros de políticas de NetWorker Server siguen las jobsdB Retención (valor predeterminado: 72 horas). Una vez transcurrido este tiempo, se purgan los registros de la sesión de respaldo de VM; sin embargo, se puede encontrar en el dispositivo vProxy: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE

Causa

Este problema se produce en el nivel de VMware. Hay varias causas posibles:
 

  1. Valores de atributos personalizados no válidos o no soportados
  • Caracteres que no son UTF-8
  • Caracteres de control
  • Secuencias de escape mal formadas
  • Cadenas excesivamente grandes (de herramientas de automatización o scripts)
  1. Definiciones de atributos personalizados huérfanas o incoherentes. Esto ocurre cuando una máquina virtual hace referencia a una clave de atributo personalizada, pero la definición de atributo personalizado correspondiente se eliminó o es inaccesible en vCenter. Esta condición puede aparecer cuando se eliminan atributos personalizados en el nivel de vCenter sin eliminarlos primero de todas las VM. Esto puede aparecer en entornos de larga duración actualizados en varias versiones de vCenter.
  2. Permisos de vCenter insuficientes para administrar atributos personalizados.
  3. Atributos residuales que quedan de las operaciones interrumpidas de vProxy.

Resolución

Para cada una de las causas descritas:

  1. Revise los atributos personalizados de la VM en VMware vSphere. Identifique si alguno de los conflictos de atributos personalizados se plantea en la sección Causa . Consulte con el administrador de VMware si se pueden eliminar los atributos personalizados (incluso si se trata de pruebas de respaldo temporales). Si los respaldos se realizan correctamente sin los atributos personalizados, considere su impacto en la funcionalidad de respaldo y determine si son necesarios o se pueden desactivar. 
    NOTA: Cualquier atributo personalizado relacionado con vProxy se puede eliminar de manera segura. Estos son atributos de marcador de posición y se crean automáticamente durante la próxima operación de NetWorker VMware Protection (NVP). Consulte el punto cuatro para obtener más información.
  2. El administrador de VMware debe investigar las definiciones de atributos personalizados huérfanas o incoherentes en el entorno vSphere.
  3. La cuenta de usuario de VMware utilizada para las operaciones de NetWorker VMware Protection debe tener permisos Global :>administrar atributos personalizados en vSphere. En la sección NetWorker VMware Integration : privilegios mínimos requeridos de cuenta de usuario de vCenter , se detallan todos los permisos necesarios para las operaciones de respaldo y restauración. La documentación de NetWorker está disponible a través de: Compatibilidad con NetWorker | Manuales y documentos (debe iniciar sesión con su cuenta de soporte de Dell).
  4. Si los atributos personalizados residuales de vProxy no se actualizaron correctamente, se pueden eliminar manualmente según el punto 1. Alternativamente, el ProxyHC cleanup se puede utilizar para limpiar información obsoleta, consulte: NVP-vProxy: Cómo usar la herramienta de evaluación del estado ProxyHC en el dispositivo vProxy

Información adicional

El paquete de soporte del servidor vCenter puede proporcionar contexto adicional sobre esta falla. Revise los registros de vCenter Server (/var/log/vmware/vpxd/vpxd.log) puede proporcionar mensajes adicionales con respecto a CustomFieldsManager o vim.fault observado durante el respaldo.

Productos afectados

NetWorker
Propiedades del artículo
Número del artículo: 000031248
Tipo de artículo: Solution
Última modificación: 07 abr 2026
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.