NVP vProxy: el plug-in de vSphere Web Client informa la instalación correcta, pero no aparece
Resumen: El complemento vSphere Web Client informa la instalación correcta, pero no aparece
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
La integración de NetWorker VMware Protection se configura con el vProxy Appliance. Se selecciona vCenter Server, en VMware View, en NetWorker Management Console (NMC) para instalar el plug-in de vCenter. Los resultados de instalación del plug-in de vCenter muestran que se instaló correctamente, pero el cliente web de vSphere no muestra el plug-in de Dell EMC NetWorker.
Causa
Es posible que el plug-in de vSphere Web Client se haya instalado en un estado incoherente o que los archivos de instalación del plug-in anteriores interfieran con la nueva instalación del plug-in.
Resolución
Elimine los registros existentes del plug-in de Dell NetWorker del servidor vCenter. Las instrucciones también están disponibles en la sección "Remove the flash-based vCenter plug-in from the vSphere Web Client" de la Guía de integración de VMware de Dell EMC NetWorker. Para su conveniencia, en el artículo de la base de conocimientos, se proporcionan pasos más detallados para eliminar el registro del plug-in de Dell EMC NetWorker.
1) Inicie sesión en vCenter Managed Object Browser (MOB) con la cuenta administrator@vsphere.local. Se puede acceder a la placa base desde un navegador web que puede comunicarse con el nombre de host o la dirección IP de vCenter: https://vcenter_name/mob
Nota: Cuando aparezca "Method Invocation Result: void", puede especificar el próximo plug-in y eliminarlo. Repita este método para cada uno de los archivos com.emc.networker... Plugins.
2) Inicie sesión en vCenter Server a través de SSH.
3) Reinicie el servicio vSphere Web Client en vCenter Server. Consulte: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenter.configuration.doc/GUID-A0BB46B0-DE71-4C62-A5BF-22B17ED8AA98.html
1) Inicie sesión en vCenter Managed Object Browser (MOB) con la cuenta administrator@vsphere.local. Se puede acceder a la placa base desde un navegador web que puede comunicarse con el nombre de host o la dirección IP de vCenter: https://vcenter_name/mob
a) Cuando haya iniciado sesión en la PLACA base, seleccione el contenido
b) En la ventana Contenido del servicio, seleccione Administrador de extensión
c) En la ventana Lista de extensiones, seleccione más...
d) Habrá 3 extensiones para el plug-in de cliente web de NetWorker vSphere, las que se deberán eliminar:
b) En la ventana Contenido del servicio, seleccione Administrador de extensión
c) En la ventana Lista de extensiones, seleccione más...
d) Habrá 3 extensiones para el plug-in de cliente web de NetWorker vSphere, las que se deberán eliminar:
e) En Métodos, seleccione UnregisterExtension
f) En la ventana UnregisterExtension, ingrese el nombre de la extensión y seleccione Invocar método:
f) En la ventana UnregisterExtension, ingrese el nombre de la extensión y seleccione Invocar método:
Nota: Cuando aparezca "Method Invocation Result: void", puede especificar el próximo plug-in y eliminarlo. Repita este método para cada uno de los archivos com.emc.networker... Plugins.
g) Actualice la ventana MOB ExtensionManager, los plug-ins com.emc.networker deben desaparecer de la lista de extensiones.
2) Inicie sesión en vCenter Server a través de SSH.
a) Com.emc.networker.. dir se debe eliminar de la base de datos de vCenter Server.
Linux: /etc/vmware/vsphere-client/vc-packages/vsphere-client-iso
Nota: Esta ubicación puede variar según la versión de vCenter. Consulte la documentación de VMware si el plug-in no se puede encontrar en las rutas indicadas anteriormente
Por ejemplo:
Nota: Esta ubicación puede variar según la versión de vCenter. Consulte la documentación de VMware si el plug-in no se puede encontrar en las rutas indicadas anteriormente
Por ejemplo:
root@vcenter65 [ ~ ]# ls -l /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
total 8
drwxr-xr-x 3 vsphere-client users 4096 Nov 6 17:02 com.emc.networker-9.2.1246
drwxr-xr-x 3 vsphere-client users 4096 Jul 6 17:06 com.vmware.vsan.health-6.5.0
b) El plug-in se puede eliminar eliminando la carpeta com.emc.networker.
3) Reinicie el servicio vSphere Web Client en vCenter Server. Consulte: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenter.configuration.doc/GUID-A0BB46B0-DE71-4C62-A5BF-22B17ED8AA98.html
4) Espere hasta que se hayan iniciado los servicios del cliente web de vSphere, podrá iniciar sesión en el cliente web de vSphere.
5) Inicie sesión en NMC y vuelva a intentar la instalación del plug-in.
6) Cierre sesión en el cliente web de vSphere y vuelva a iniciar sesión.
5) Inicie sesión en NMC y vuelva a intentar la instalación del plug-in.
6) Cierre sesión en el cliente web de vSphere y vuelva a iniciar sesión.
Productos afectados
NetWorkerProductos
NetWorkerPropiedades del artículo
Número del artículo: 000166557
Tipo de artículo: Solution
Última modificación: 30 abr 2025
Versión: 5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.