DDBEA 4.5 – com SQL 2014 e 2016 no mesmo sistema – não é possível fazer log-in na instância do SQL Server.

Resumen: Plug-in do DDBEA Microsoft APP Agent instalado no SQL Server 2014 e 2016 Problema em que qualquer backup falha: não é possível fazer log-in na instância do SQL Server.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Falha do plug-in do Data Domain Backup Enterprise Agent – DDBEA ao executar backups do SQL Server.
 

ddbmsqlsv NSR critical Cannot login to SQL Server Default Instance.

ddbmsqlsv: Unable to complete the SQL connection

Causa

Ambiente
O SQL Server 2014 está instalado e uma instância do SQL 2014 está em execução.  O SQL Server Management Studio (SSMS) está usando a versão 2014. 
No mesmo sistema, o software SQL Server 2016 também está instalado.

Verificadas as permissões do usuário conectado e ele tem todas as permissões necessárias. 
O usuário pode executar backups nativos do SQL, a partir das ferramentas SSMS, OSQL e SQLCMD.

A investigação revelou, algum tempo depois que o SQL Server 2016 foi instalado, que também.
  •  O software SQL 2016 foi parcialmente desinstalado (mas não completamente)
  •  Ou alguns arquivos da instalação do SQL 2016 foram excluídos.      Isso fez com que os drivers do SQL 2016 ADO.Net fossem removidos.  ** Esses drivers são necessários para que o DDBEA se conecte à instância do SQL Server.
  • A instância do SQL Server e o SSMS, ambas da versão 2014, não têm problemas.
  • O software SQL Server 2016 não foi removido correta ou completamente, isso fez com que qualquer instalação do DDBEA tentasse se conectar usando os drivers de ADO.net SQL 2016 ausentes.
Qualquer backup de qualquer banco de dados falhará com o erro. 
 ddbmsqlsv NSR critical Cannot login to SQL Server Default Instance.
 ddbmsqlsv: Unable to complete the SQL connection

Resolución

Para resolver,

primeiro desinstale o DDBEA.   Em seguida, execute um dos seguintes:

A) se a versão necessária do SQL for 2014, desinstale e reinstale o SQL Server 2014

B) se a versão necessária do SQL for 2016 e não tiver sido desinstalada corretamente, execute uma nova instalação do SQL Server 2016. 

Depois disso, reinstale o DDBEA.
Propiedades del artículo
Número del artículo: 000161829
Tipo de artículo: Solution
Última modificación: 27 may 2024
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.