NetWorker: AIX Client backups fails with "not properly configured" message
Resumen: The NetWorker AIX client backup with to complete with a configuration error message. The NetWorker Management Console (NMC) shows either a Blank hostname or Unicode Character as hostname. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
The AIX Client NSRLA Certificate shows a blank name or a Unicode Character "▒" (U+2592) for the hostname in /nsr/res/nsrladb.
The backup session log shows:
DD/MM/YY HH:MM:SS lgto_parms failed: Client ' ' is not properly configured on the NetWorker Server 175297:save: Unable to set up the direct save with server '###.###.###': Client ' ' is not properly configured on the NetWorker Server 175024:save: Cannot open a save session with NetWorker server '###.###.###': Client ' ' is not properly configured on the NetWorker Server
Causa
The AIX client /etc/hosts file record is missing the local details or an invisible Unicode Character "▒" added. The affected AIX client uses the /etc/hosts when creating the NSRLADB database certificate and the entry is causing the problem.
Example blank entry in the NSRLADB database:
my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
type: NSRLA;
administrator: root, "user=root,host=";
Example Unicode character in the NSRLADB database:
my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
type: NSRLA;
administrator: root, "user=root,host=▒";
Resolución
Include the AIX client hostname and IP in the local /etc/hosts file to populate the local NSRLADB database.
- Open an SSH session to the AIX client.
- Make a copy of the existing hosts file:
cp /etc/hosts /etc/hosts_orig - Stop the NetWorker services:
nsr_shutdown - Rename the existing NetWorker res directory:
mv /nsr/res /nsr/res_old - Start the NetWorker services:
/etc/rs.nsr - Validate the hostname in the online NSRLADB database:
nsradmin -p nsrexec - Validate the hostname in the offline NSRLADB database:
nsradmin -d /nsr/res/nsrladb - Clear the NSR Peer information about NetWorker Server: NetWorker: Fixing inconsistent NSR peer information
- Run a backup of the affected AIX client.
Información adicional
If the folders /nsr/res, or /nsr/res/nsrladb cannot be renamed, perform the following:
- Fix the name in the
nsrladbas text file to call itnsrladb_manually_fixed. - Use the
nsradmin"-i" option to input and merge the nsrladb:
# nsradmin -d /nsr/res/nsrladb -i /tmp/nsrladb_manually_fixed
- Stop NetWorker services:
nsr_shutdown - Start NetWorker services:
/etc/rs.nsr
Productos afectados
NetWorkerProductos
NetWorker FamilyPropiedades del artículo
Número del artículo: 000202546
Tipo de artículo: Solution
Última modificación: 01 abr 2026
Versión: 3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.