Isilon PowerScale 9.3 veya üstü Webui'de rol değiştirilamamaktadır. "Bir sorun oluştu. Json'ı kişilik olarak ayrıştıramıyor"
Resumen: OneFS 9.3 veya üzeri sürümler için webui'deki rolleri değiştirmeyi denerseniz gönderme sırasında aşağıdaki hata mesajı alabilirsiniz (son adım) "Bir sorun oluştu. Json'ı kişilik olarak ayrıştıramıyor." ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Webui'de rolleri değiştirmek, değişikliği "göndermeye" çalışırken aşağıdaki hataya neden olur: "Bir sorun oluştu. json'ı kişilik olarak ayrıştırılamıyor"
Cli'yı kullanarak da herhangi bir sorun olmadan değiştirebilirsiniz.
CLI üzerinden rolü görüntülerken bazı üyelerin yalnızca UID ile listelenmiş olduğunu görürsünüz.
Aşağıdaki örnek:
Papi günlüklerinde benzer hatalar veya STACK görürsünüz:
Kullanıcı uid tarafından kontrol ettiyseniz bunlar mevcut değildir:
Webui'de hata görülüyor:
Cli'yı kullanarak da herhangi bir sorun olmadan değiştirebilirsiniz.
CLI üzerinden rolü görüntülerken bazı üyelerin yalnızca UID ile listelenmiş olduğunu görürsünüz.
Aşağıdaki örnek:
onefs93-1# isi auth roles view AuditAdmin
Name: AuditAdmin
Description: View all system configuration settings.
Members: admin
test1
test2
UID:2003
WINSERVER\test_user
Privileges
ID: ISI_PRIV_LOGIN_CONSOLE
Permission: r
Papi günlüklerinde benzer hatalar veya STACK görürsünüz:
onefs93-1# isi_for_array -s 'grep 2023-03-24 /var/log/isi_papi_d.log | grep -i "Failed to find user for" | grep UID'
onefs93-1: 2023-03-24T12:38:55.132849-07:00 onefs93-1(id1) isi_papi_d[5511]: STACK Failed to find user for 'UID:2003': No such user from --- (---:0): isi_exception::isi_exception(int, char const*, __va_list_tag*) (OFFSET:134) api_exception::api_exception(api_error_code, char const*, ...) (OFFSET:146) auth_user_handler::http_get(request const&, response&) (OFFSET:1098) uri_handler::execute_http_method(request&, response&, bool, bool) (OFFSET:2480) uri_manager::execute_request(request&, response&, bool, bool, bool, bool, bool) (OFFSET:1550) std::__1::basic_filebuf >::basic_filebuf(void) (OFFSET:7588) std::__1::basic_filebuf >::basic_filebuf(void) (OFFSET:9908) typeinfo name for std::__1::basic_filebuf > (OFFSET:40557) typeinfo name for std::__1::basic_filebuf > (OFFSET:37691) ADDRESS (UNKNOWN:2363392)
Kullanıcı uid tarafından kontrol ettiyseniz bunlar mevcut değildir:
onefs93-1# isi auth users view --uid=2003
Failed to find user for 'UID:2003': No such user
Webui'de hata görülüyor:
Causa
Bu sorun, daha önce değiştirmek istediğiniz role eklenen kullanıcıların çıkarılmasından kaynaklanmaktadır.
Kullanıcı veya kullanıcıların silinmesi, "UID" öğesini üye listesinden tamamen kaldırmaz ve tüm üyeleri çözemezse.
Kullanıcı veya kullanıcıların silinmesi, "UID" öğesini üye listesinden tamamen kaldırmaz ve tüm üyeleri çözemezse.
Resolución
Değiştirmek istediğiniz rolün üyeleri yalnızca UID'ye sahip kullanıcıların listelenmiş olduğunu gösteriyorsa yalnızca UID'ye sahip üyelerin mevcut olduğunu doğrulayın.
Var olmayan UID'leri, değiştirmek istediğiniz rolden kaldırın:
Örnek:
Rolden tüm var olmayan UID'leri çıkardıktan sonra Webui üzerinden rolü değiştirin.
UID ile birden fazla üye listelenmişse ve bu kullanıcılar mevcut değilse, mevcut olmayan tüm UID'ler kaldırılmalıdır.
isi auth users view --uid=
Var olmayan UID'leri, değiştirmek istediğiniz rolden kaldırın:
isi auth role modify --remove-uid=
Örnek:
isi auth role modify AuditAdmin --remove-uid=2003 (isi kimlik doğrulaması rolünü değiştir AuditAdmin --remove-uid=2003)
Rolden tüm var olmayan UID'leri çıkardıktan sonra Webui üzerinden rolü değiştirin.
UID ile birden fazla üye listelenmişse ve bu kullanıcılar mevcut değilse, mevcut olmayan tüm UID'ler kaldırılmalıdır.
Productos afectados
Isilon, PowerScale OneFSPropiedades del artículo
Número del artículo: 000211554
Tipo de artículo: Solution
Última modificación: 30 jun 2023
Versión: 5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.