PowerVault MD24xx: Solución de problemas de configuración externa

Resumen: En este artículo, se explica qué hacer si un adaptador PERC coloca una o más unidades de un gabinete PowerVault MD24xx en un estado de configuración externa. Este artículo se centra en las razones por las que todas las unidades son colocadas como externas y cómo solucionar estos problemas. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

El primer error es una pérdida de comunicación con el gabinete JBOD MD24xx. Cuando se restaura la conexión, el adaptador PERC coloca una o más unidades físicas del gabinete MD24xx en un estado de configuración externa.

Configuración externa
Una configuración externa es un conjunto de unidades de discos físicos que tienen una configuración RAID que no administra la controladora RAID a la que está conectada. Además, la configuración de disco también está presente en cada disco del arreglo. Si la configuración de un disco no coincide con lo que la controladora tiene para ese disco, la controladora lo coloca en un estado de configuración externa.

Es importante comprender que las unidades en estado externo son un síntoma de un problema mayor, NO es el problema en sí. Para empezar, solucione el problema por el cual el adaptador PERC colocó las unidades en estado externo. Lo más probable es que se trate de un restablecimiento de la conexión SAS en el almacenamiento JBOD MD24xx conectado, los cables SAS, el propio adaptador PERC o, posiblemente, un problema relacionado con la alimentación.

Causa

Puede ocurrir que un adaptador PERC informe una configuración externa por varios motivos, incluidos, entre otros, los siguientes:

  • Transferir unidades físicas de un servidor a otro o intercambiar ranuras puede ocasionar que la controladora identifique los discos como una configuración externa.

  • Reemplazar el adaptador PERC puede hacer que los arreglos que antes funcionaban ya no se reconozcan después de una interrupción en la alimentación.

  • Es posible que ya exista una configuración RAID en un conjunto de unidades de reemplazo.

  • Volver a insertar o quitar un cable de gabinete externo (o si el cable está suelto) mientras el sistema operativo está en ejecución puede dar lugar a una configuración externa tras restablecerse la conexión.

  • Un reinicio o un ciclo de apagado y encendido incorrectos de un servidor con almacenamiento externo conectado pueden provocar que los discos se coloquen en un estado externo.

  • Se produce un evento relacionado con la alimentación que provoca el restablecimiento o un ciclo de apagado y encendido del gabinete. Esto podría estar relacionado con una PSU defectuosa, una interrupción de la alimentación o un restablecimiento de CPLD en el gabinete.

Resolución

El JBOD MD24xx sigue siendo un producto bastante nuevo y funciona de manera diferente en varios aspectos en comparación con los dispositivos JBOD anteriores, como MD12xx, MD14xx, MD3060e o ME484. Se realizaron cambios en la forma en que se valida para la instalación, la configuración y el uso.

Recientemente, hemos visto un aumento en las unidades que el adaptador PERC coloca en un estado externo en las unidades instaladas en el gabinete JBOD MD24xx adjunto. Lo principal que todos los casos tienen en común es que todos están conectados a un adaptador PERC, que es desde donde se origina un estado de configuración externa.

La configuración externa se puede importar de inmediato para recuperar el acceso a los datos. Sin embargo, si no se descubre la causa raíz del restablecimiento de la conexión SAS, es probable que las unidades vuelvan a colocarse en un estado externo. El adaptador PERC suele identificarse erróneamente como la causa del problema. En la mayoría de los casos, no es el adaptador PERC el causante de este problema. Como se indicó anteriormente, el estado de configuración externa es un síntoma del problema, NO suele ser el problema. Cualquier interrupción a lo largo de la cadena de comunicación SAS puede provocar que el adaptador PERC coloque los discos en un estado externo si no reconoce la configuración RAID cuando se restaura la conexión.

Los siguientes son pasos para ayudar a analizar y solucionar problemas de lo que está causando que el adaptador PERC coloque las unidades en un estado externo.
 

  • Confirme que sea una configuración soportada, según matriz de soporte:

    • Sistemas operativos compatibles

      • Windows Server 2022

      • Windows Server 2019

      • Red Hat Enterprise Linux 9.1

      • Red Hat Enterprise Linux 9.0

      • Red Hat Enterprise Linux 8.7

      • Red Hat Enterprise Linux 8.6

      • SUSE Linux Enterprise Server 15 SP5

    • Adaptadores PERC soportados

      • PERC H840

      • PERC H965e

    • Cables SAS soportados (P/N: F82HG, NX1XW, W1W05, 3J2R2, 39Y00, TV165)

      • SAS-4 (24 Gbps: pestaña blanca)

    • Discos duros soportados

      • Consulte la matriz de soporte para el arreglo JBOD MD24xx específico.

  • Confirme los pasos realizados para solucionar problemas de los cables SAS.

    • ¿Hay al menos un cable SAS conectado a cada EMM en el arreglo JBOD MD24xx? Con los JBOD MD24xx, debe haber cableado redundante; el cableado único a un EMM NO es soportado.

    • ¿Se volvieron a insertar o se reemplazaron los cables SAS?

    • ¿Se utilizan los cables SAS-4 (pestaña blanca) que se enviaron con el arreglo JBOD MD24xx?

  • ¿Está encendido el LED del puerto del EMM?

    • El LED del puerto debe ser de color amarillo fijo si utiliza un terminal/cable SAS-3 (pestaña azul).

    • El LED del puerto debe ser de color verde fijo si utiliza un terminal/cable SAS-4 (pestaña blanca).

Nota:
Un terminal/cable SAS-3 es un adaptador HBA SAS de 12 Gbps o un cable (con una pestaña azul), como un adaptador PERC H840 o HBA355e. Los cables SAS-3 no son compatibles para su uso con el arreglo JBOD MD24xx.


Un terminal/cable SAS-4 es un adaptador HBA SAS de 24 Gbps o un cable (con una pestaña blanca), como un PERC H965e. Los cables SAS-4 son los únicos compatibles para su uso con los arreglos JBOD MD24xx.

Si el cable SAS o el adaptador son de una versión SAS-3, el LED del puerto es de color amarillo fijo.

  • ¿Qué piezas (si las hay) se reemplazaron?

  • Confirme las actualizaciones de firmware y controlador.

    • ¿Cuáles son las revisiones del firmware y del controlador del adaptador PERC? Actualice ambas a las revisiones más recientes.

    • ¿Cuál es la revisión del firmware del EMM de JBOD MD24xx? Actualice a la revisión más reciente.

    • ¿Cuál es la revisión del firmware del disco duro en las unidades que se encuentran en estado externo? Actualice a la revisión más reciente.

    • ¿El cliente tiene instaladas las actualizaciones de Windows más recientes?

    • ¿Se realizaron actualizaciones recientes de firmware o de controladores para el EMM, las unidades, PERC, etc.?

  • ¿Qué otros pasos de solución de problemas se realizaron?

  • ¿Se realizaba algún tipo de mantenimiento en el servidor que implicó un reinicio del servidor y, por extensión, del arreglo de almacenamiento MD24xx conectado?

  • ¿Qué registros se recopilaron (registros de eventos del sistema de Windows, TSR, EMCGrab, salida de SHMCLI, paquetes vm-support, etc.)?

    • Recopile los registros de diagnóstico del host ESXi (es decir, el paquete vm-support). Consulte el artículo de VMware para obtener detalles. 

    • Recopile un sosreport de Linux. La mayoría de las distribuciones de Linux incluyen la utilidad sosreport. Consulte el artículo de Red Hat para obtener detalles.

    • Recopile una captura de EMC mediante las instrucciones del siguiente artículo:

    • Recopile los resultados de SHMCLI de PowerTools mediante el script HWInfo. Comuníquese con el equipo de soporte técnico de Dell para recopilar estos resultados.

    • Recopile los resultados de los EMM de JBOD PowerVault mediante una conexión en serie. Comuníquese con el equipo de soporte técnico de Dell para recopilar estos resultados.

  • Confirme qué versión de iDRAC utiliza el cliente.

    • Se lanzó iDRAC 7.10.30.00.

      •  

      • Compatibilidad con PERC H965e en servidores 16G y HBA 355e en servidores 15G y 16G.

    • Se lanzó iDRAC 7.00.00.171.

      • Compatibilidad con PERC H840 y HBA355e en servidores 14G.

Si no se respeta alguna las instancias anteriores, pueden surgir problemas. Corrija todo o la mayor parte de lo anterior antes de realizar una escalación o repetición. Recuerde buscar restablecimientos de la conexión SAS en los registros, lo que, en definitiva, lo llevará a la solución de este problema.

Productos afectados

PowerVault MD2412, PowerVault MD2424, PowerVault MD2460
Propiedades del artículo
Número del artículo: 000225870
Tipo de artículo: Solution
Última modificación: 04 oct 2024
Versión:  8
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