Las rutas de Dell Networking OS10 no están instaladas

Resumen: El problema se debe a que las nuevas rutas no se instalan en el hardware Broadcom en los switches Dell S5248F. OS10 puede aprender nuevas rutas, pero no puede instalarlas en las tablas de hardware de Broadcom. Este problema afecta a todas las plataformas y todas las versiones de OS10, pero se puede mitigar mediante la configuración del switch o diferentes plataformas en las que las tablas sean más grandes que S5200. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

  • Recopilación de información:
    • Use el comando sosreport Comando para recopilar información de los registros del sistema y las tablas de hardware.
    • Recopile mapas de topología y detalles de configuración.
    • hshell -c "l3 info" muestra si se agotó el espacio de tablas.
  • Identificación del problema:
    • Compruebe qué rutas no funcionan y si los dispositivos no se pueden comunicar.
    • Con OS10 show , puede ver las rutas en la tabla de enrutamiento.
    • Desde el kernel OS10, ping Funciona entre el origen y el destino.
    • La ruta no se puede ver en el defip tabla mediante la hshell comando.
      • Para IPv4, hshell -c "´l3 defip show" se puede utilizar para comprobar la entrada de la ruta.
      • Para IPv6, hshell -c "l3 ip6route show" se puede utilizar para comprobar la entrada de la ruta.
      • Compruebe el uso de la tabla actual con hshell -c "l3 info" comando.
    • También puede extraer el comando journalctl salida en busca de las entradas que aparecen a continuación.
//========

[ROUTE:HAL-RT-DR], Error: hal_fib_route_add vrf_id: 8, prefix: 201.54.14.249, prefix_len: 32, hal_err: -1 (Failure)
base_nas[err]:  [ev_log_t_SAI_ROUTE:Switch Id: 0], Failed to add route in Unit 0. Err: Table full.
base_nas[err]:  [ev_log_t_SAI_ROUTE:Switch Id: 0], Route Add failed

//========
  • El cálculo del uso de la tabla es el siguiente:
Example:

ip6 routes – 12 (show ipv6 route summary including all VRF)
ipv4 routes - 12 (show ip route summary including all VRF)
total routes = 36 = ip6-routes*2 + ip4-routes  <------ Note: IPv6 takes two entries.

l3 info shows the number of used/total-entries hosts/route entries.

//=======
OS10#system "sudo hshell -c 'l3 info'"
 hosts            :     12 / 147456
routes           :     31 /  32768
nexthops         :      9 /  65536
ecmp_groups      :      0 /   4096
overlay_ecmp_defrag  :      0
underlay_ecmp_defrag :      0
//=======

Causa

  • Causa raíz:
    • Este problema podría ocurrir en cualquier versión de OS10.
    • El problema se debe a que la tabla de hardware de Broadcom está llena, lo que impide que se agreguen nuevas rutas.
  • Documentos complementarios:
    • Consulte la Guía del usuario de Dell SmartFabric OS10 más reciente para conocer las limitaciones detalladas de hardware y uso de comandos.
    • Límites de hardware para la plataforma S5200:

Tabla de hardware

Resolución

  • No hay intención de corregir este problema en el código OS10 porque es una limitación de hardware. Trabaje con algunas de las siguientes opciones para solucionar esta limitación
    • Compruebe el perfil de hardware actual con el siguiente comando y adapte las rutas y los hosts dentro de los límites. 
Note: The command was taken from s5248f.
OS10# show hardware forwarding-table mode all

 Mode             default scaled-l2  scaled-l3-routes scaled-l3-hosts
 L2 MAC Entries   163840   294912     32768            98304
 L3 Host Entries  147456   16384      16384            212992
 L3 Route Entries 32768    32768      131072           98304
  • Supervisión del espacio de tablas mediante comandos "l3 info" En hshell menú.
  • Utilice diferentes configuraciones para suprimir las rutas innecesarias o las entradas de host instaladas en el switch.

Productos afectados

PowerSwitch, SmartFabric OS10 Software
Propiedades del artículo
Número del artículo: 000322394
Tipo de artículo: Solution
Última modificación: 28 ene 2026
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.