NetWorker: Troubleshooting Tape Library Readiness Problems in NetWorker
Resumen: This article assists NetWorker support and backup administrators in determining why a configured robot fails to enter a Ready state within NetWorker.
Síntomas
- Detected and configured library will does not enter Ready state for operations
- The library is not available for backup operation
- The library does not show as Ready in the NetWorker Management Console (NMC) Devices -> Libraries section.
- Library operations all fail without attempt, returning various error messages
nsrjb: Jukebox <library_name>: (Not ready to accept commands)15776:nsrjb: No jukeboxes are currently usable.
Causa
If library configuration worked previously and suddenly encounters an issue, consider possible changes that may be impeding detection and configuration:
- Robot, switch or adapter firmware, driver or configuration change
- Change in host access to library (transport zoning, configuration, or firmware change)
- Addition, replacement or removal of drives, tape cartridges or other library components
- Change of NetWorker software version, Operating System patches
- Any hardware event such as power loss or reboot of any component in the data path
- Discrepancies between NetWorker configuration and library (for example, tape cartridges moved outside of NetWorker's control)
If the library has never worked - confirm that the hardware is supported in the NetWorker Hardware Compatibility Guide (Requires Dell Support Account Sign-In). Remember that it is possible for a library to be partially functional; discovery alone does not guarantee usability or supportability.
Resolución
To diagnose library Ready‑state issues, first consider any recent changes. Next, isolate each component of the process and test it independently.
-o:d switch. The items which are not are restricted to those operations which might be considered to be dangerous if attempted manually.
For more information about NSRGET, see: NetWorker: How to Use the NSRGet NetWorker Data Collection Tool
Library Ready: Communications:
- Detection: Ensure that the host can still see and communicate with the robot; if there has been a connectivity change of any kind, or power cycle of anything in the datapath, confirm detection:
- Access: Ensure that the robot is responsive by testing a battery of commands as per the following article:
- Data collection: As noted,
nsrget -o:dcan collect most of the data required to verify library responsiveness up to this stage.
Library Ready: Initialization:
- Element Initialization: This is a library-level activity which allows the robot to prepare its elements and confirm the location of tape cartridges before coming online for SCSI client access. Simulate with the command:
ielem -a <changer address>
If this command fails - it may signal a deeper robot-level problem which requires vendor support. You can work around the issue by disabling the INIT command through Jukebox Features, but this reduces the overall capability:no_init_elem_stsno_start_init_elem_sts
Library Ready: NetWorker Configuration:
There are several configuration properties which may affect the library becoming ready at a logical level:
- NSR Jukebox: Control Port value. This is set during normal library configuration, but if the handle is changed, invalidating the setting, then the library fails to start since the address to communicate with it is wrong. To correct:
- Disable the library resource in NetWorker
- Determine the new library address (
inquire -s) - Use the
nsradminutility to update thecontrol portfield - Reenable the library and test
- NSR Jukebox: Jukebox Features value. This value is also automatically set during configuration, and some of the options may be enabled or disabled, depending on need and specific knowledge of the library model itself. The most common reason to change it is described above.
- NSR Jukebox: Loaded volumes/volumes. On startup, in some modes, if the
nsrjb -Coutput does not match the output ofsjirdtag <changer address>in terms of what tape cartridges reside in what elements, the library may fail to become ready. To correct, usesjimmcommands to move volumes into the elements that NetWorker expects. - NSR Jukebox: Available slots. If the number of slots the robot reports does not match the configured value in the NSR Jukebox resource, the library may not become ready.
- NSR Jukebox: Hardware ID/Existing drive IDs. If the serial number for either robot or drives changes, or is misreported, the library may not be put into ready state.
Library Ready: Other hardware and environment issues
The following prevents the library reaching a Ready state in NetWorker:
- Library robot door is open (NetWorker library resource should always be disabled before doing this)
- Serial number, slot count, or other property changes to the library
- Other host or process locking the robot resource from nsrlcpd process accessing it
- Tape cartridge stuck in drive, slot, or robotic hand
- Other transient hardware issue which may prevent robot responsiveness
Library Ready: Debugging
- Set the debug variables in the System Environment (Windows) or the /nsr/nsrrc startup script (Linux) in order to get richer debugging data:
SJI_DEBUG=9LUS_DEBUG=9CDI_DEBUG=9SCSI_DEBUG=9JBDEBUG=9
- Disable the library in NetWorker, change
debug trace levelto 5, and reenable for logging - Optionally, and depending on the Operating System, you may be able to collect traces and forced dumps for the library during its startup phase
If none of the above suggestions help, engage support as appropriate from your Library vendor if the evidence collected from the debug suggests any internal anomalies.