AppSync. Сбой восстановления SQL из-за отсутствия файлов ldf (журнал sql).
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
AppSync не удается восстановить базу данных SQL на хосте монтирования.
В событиях плана технического обслуживания будет показано следующее:
Unable to recover database MyDB on the instance MySQL-QA. See the host plug-in log, application event log, and the SQL Server error log for details.
В журнале событий приложений операционной системы будет отображаться следующее:
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnose and correct the operating system error, and retry the operation.
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnose and correct the operating system error, and retry the operation.
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnose and correct the operating system error, and retry the operation.
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnose and correct the operating system error, and retry the operation.
В журнале подключаемого модуля AppSync на хосте монтирования отобразится следующее:
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
Causa
Ошибка программного обеспечения
Resolución
AppSync 4.0 устраняет эту проблему.
Información adicional
В примечаниях к выпуску AppSync 4.0 эта проблема не упомянута в разделе «Исправлено», однако было подтверждено, что исправление содержится в AppSync 4.0
Выполните модернизацию до AppSync 4.0, чтобы устранить эту проблему.
Выполните модернизацию до AppSync 4.0, чтобы устранить эту проблему.
Productos afectados
AppSyncProductos
AppSyncPropiedades del artículo
Número del artículo: 000170225
Tipo de artículo: Solution
Última modificación: 20 oct 2025
Versión: 6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.