PowerFlex 4.X: Los sistemas MDS se muestran vacíos
Resumen: En este artículo, se explica cómo resolver problemas de inventario en el sistema MDS PowerFlex causados por la falta de direcciones IP del MDM, como lo indican los registros kubectl de MDS y los registros de LIA en los MDM. ...
Síntomas
- No se muestra el inventario del sistema MDS PowerFlex.
- Los registros kubectl de MDS muestran un error 404 cuando se intenta obtener MdmIps desde el administrador de LCM, lo que indica que
mdm.ip.addressesno está presente y no se puede conectar al clúster.
23:21:28.383 [|https-openssl-nio-443-exec-4] INFO c.e.s.s.services.GeneralServiceImp - Can't fetch MdmIps from LCM manager at https://thin-deployer:9433/asm/device/mdm_cluster_info?certname=scaleio-block-legacy-gateway-mds. Request returned response code 404, respons e message: Not Found 23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.services.GeneralServiceImp - mdm.ip.addresses is missing 23:21:28.383 [|https-openssl-nio-443-exec-4] INFO c.e.s.s.services.GeneralServiceImp - Got Cluster IPs 23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.s.ConnectionServiceImpl - Failed connecting to cluster 23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.r.SystemRepositoryImpl - com.emc.s3g.scaleio.common.gateway.ScaleIORemoteRuntimeException: Failed connecting to cluster: no MDM IP is set
- Los registros de LIA en los MDM indican una falla en la ejecución
scli --reset_management_trust, probablemente debido a lamgmt_ca.pemEl certificado no se agrega al almacén de confianza del MDM.
2024/01/03 18:06:18.061168 MED:7f905831bdb0:liaCmd_ResetMgmtTrust:05502: Executing command : scli --reset_management_trust --mdm_port 8611 --i_am_sure 2024/01/03 18:06:18.377107 LOW:7f905831bdb0:liaCmd_ResetMgmtTrust:05508: Run command [scli --reset_management_trust --mdm_port 8611 - -i_am_sure] returned Value: 1 [0-is success] 2024/01/03 18:06:18.377119 LOW:7f905831bdb0:liaCmd_ResetMgmtTrust:05539: MDM Reset Security command failed, cmdRc = 1
Causa
mgmt_ca.pem El certificado, en particular, debe establecerse correctamente en el almacén de confianza de MDM para garantizar la recuperación correcta de la dirección IP de MDM durante la importación. Si no se reconoce este certificado, se producirán problemas de conectividad y problemas de inventario posteriores.Resolución
1- Compruebe los archivos de configuración de MDM:
Vete a.
/opt/emc/scaleio/mdm/cfg
Y enumere los certificados para asegurarse de que se generen.
Verifique la presencia del certificado mgmt_ca.pem y los últimos caracteres.
2- Actualice el almacén de confianza de la CLI:
cat /root/.scli/cli_truststore.pem
Si el certificado mgmt_ca.pem no se encuentra en el almacén de confianza de la CLI, agréguelo con.
scli --add_certificate --certificate_file /opt/emc/scaleio/mdm/cfg/mgmt_ca.pem.
3. Distribuya el certificado entre los MDM:
Asegúrese de que el mgmt_ca. El certificado PEM está presente en todos los MDM, excepto en el interruptor.
4- Elimine y vuelva a agregar el gateway de MDS:
En la página de recursos, elimine temporalmente el gateway de MDS para la solución de problemas.
5. Certificados de respaldo:
Cree respaldos de mgmt_ca.pem y mdm_mno_certificate.pem mediante el comando cp.
cp mgmt_ca.pem mgmt_ca.pem.bk cp mdm_mno_certificate.pem mdm_mno_certificate.pem.bk
6. Vuelva a descubrir MDS:
Una vez que se completen todos los pasos, vuelva a descubrir el MDS para RESTABLECER la funcionalidad adecuada del sistema.