AppSync: No se puede ejecutar el plan de servicio porque ya está en curso en otro proceso.
Resumen: En ocasiones, es posible que los usuarios descubran que un plan de servicio no se ejecuta con el siguiente error: No se puede ejecutar el plan de servicio DB47 porque ya está en curso en otro proceso. ...
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Síntomas
Cuando un usuario ejecuta un plan de servicio, se recibe el siguiente mensaje:
Registro del servidor:
Cannot run service plan DB47 because it is already in progress in another process
Salida de eventos de AppSync:
Application-Discovery TSK_000002 <server name> Cannot run service plan DB47 because it is already in progress in another process
02-07-2017 06:00:02.583 ERROR [ServicePlanBrokerCommandBean] Task Collision Object Found: <task> <id>6fd9f120-5b5e-4b0e-a130-8db604dce4a0</id> <lastModified>1486257365027</lastModified> <lastModifiedFormatted>Sun 02/05/2017 10:16:05 AM</lastModifiedFormatted> <collisionImmune>false</collisionImmune> <dsNames>DB47 </dsNames> <ids>68a77214-fdb2-4480-a976-57b1d928e0a6</ids> <numApps>1</numApps> <operation>mapping</operation> <phaseName>Application-Mapping</phaseName> <phaseType>mapping</phaseType> <phasepitId>c98ec955-09eb-4f3e-b7ae-9da121e4988f</phasepitId> <spId>e340e196-5dc0-4d1c-920c-a20d266b7308</spId> <spName>DB47</spName> </task> 02-07-2017 06:00:02.661 INFO [EventServiceBean] EVENT [TSK_000002]: Cannot run service plan DB47 because it is already in progress in another process(METADATA: TYPE-ERROR, TIME-2017-02-07
Causa
Es posible que un trabajo de AppSync deje de responder por varios motivos, tanto internos para el servidor de AppSync como externos.
Las razones internas pueden incluir (entre otras) una carga pesada de CPU (superior al 85 %) mientras se ejecuta un plan de servicio o un reinicio del servidor de AppSync durante la ejecución de un plan de servicio.
Entre los motivos externos se pueden incluir (entre otros) que un script de usuario deja de responder, lo que provoca que el plan de servicio de AppSync deje de responder mientras espera a que se complete el script. O bien, es posible que un cliente de AppSync deje de responder o responda lentamente, lo que da como resultado una aparente interrupción de respuesta del plan de servicio.
Las razones internas pueden incluir (entre otras) una carga pesada de CPU (superior al 85 %) mientras se ejecuta un plan de servicio o un reinicio del servidor de AppSync durante la ejecución de un plan de servicio.
Entre los motivos externos se pueden incluir (entre otros) que un script de usuario deja de responder, lo que provoca que el plan de servicio de AppSync deje de responder mientras espera a que se complete el script. O bien, es posible que un cliente de AppSync deje de responder o responda lentamente, lo que da como resultado una aparente interrupción de respuesta del plan de servicio.
Nota importante: Se deben realizar los pasos necesarios para confirmar que la causa del plan de servicio no está disponible y resolverlo antes de intentar la solución alternativa que se indica a continuación. La revisión de los eventos y Server.log de AppSync puede indicar dónde un plan de servicio específico dejó de responder. Por ejemplo, si un último evento en una ejecución del plan de servicio se parece al siguiente ejemplo, es posible que un script de usuario deje de responder. Es probable que detener el script en el host que lo está ejecutando permita que se complete el plan de servicio de AppSync.
2021-01-22 11:17:24.655,Post-mount script,5d6fd237-81dd-4d4b-97d4-055c3280dfa7,RSC_000007,hostname,User script results: Elapsed: 00:00:00.01
Resolución
Solución alternativa:
El siguiente método está disponible para abordar el problema. Si no está seguro de realizar esta solución alternativa o si esta solución alternativa no soluciona el problema, comuníquese con el soporte al cliente de Dell para obtener ayuda.
El siguiente método está disponible para abordar el problema. Si no está seguro de realizar esta solución alternativa o si esta solución alternativa no soluciona el problema, comuníquese con el soporte al cliente de Dell para obtener ayuda.
- Revise el tablero de la interfaz de usuario de AppSync para verificar que solo se esté ejecutando el plan de servicio que dejó de responder.
- Detenga el servicio del servidor de AppSync.
- Detenga el servicio de almacén de datos de AppSync.
- Mover el contenido de
C:\EMC\AppSync\jboss\standalone\tmp\vfsa otra carpeta (se puede eliminar más tarde). - Salir de la carpeta
C:\EMC\AppSync\jboss\standalone\tmp\vfsintacto pero vacío. - Inicie el servicio de almacén de datos.
- Inicie el servicio del servidor de AppSync.
Propiedades del artículo
Número del artículo: 000057134
Tipo de artículo: Solution
Última modificación: 18 sept 2025
Versión: 5
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