Connectrix: ​​​​​​​Data Center Network Manager Performance Manager Does Not Display Data Although Data is Collecting

Resumen: In DCNM, the performance monitor data is being collected but not displayed in the application.

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Síntomas

Performance Manager data is being collected but no data, or stops are being displayed.

Causa

Lack of space causes elasticseasrch to go into "read-only" mode, which does not allow the data to be held and displayed.

The results of the host CLI commands relate similarly to the following, in which "read-only" is identified as true 
[sysadmin@dcnm ~]$ curl -k http://127.0.0.1:9200/*/_settings [127.0.0.1]
{"san_fc_flows_rollup_2022_08_01":{"settings":{"index":{"number_of_shards":"1","blocks":{"read_only_allow_delete":"true"},"provided_name":"san_fc_flows_rollup_2022_08_01","creation_date":"1659333890440","analysis":{"analyzer":{"lowercase_keyword":{"filter":["lowercase"],"type":"custom","tokenizer":"keyword"}}}

Resolución

Check on the DCNM host:
'curl -k http://127.0.0.1:9200/*/_settings [127.0.0.1]’ and then look for the {"read_only_allow_delete":"true"} field.

Fix on Windows:
curl -XPUT -H "Content-Type: application/json" -k https://127.0.0.1:9200/_all/_settings [127.0.0.1] -d “{\“index.blocks.read_only_allow_delete\”: null}”

Fix on Linux:
curl  -XPUT -H "Content-Type: application/json" -k https://127.0.0.1:9200/_all/_settings [127.0.0.1] -d '{"index.blocks.read_only_allow_delete": null}'

Remove files on the drive associated or add to the disk space if a virtual host.
Propiedades del artículo
Número del artículo: 000205242
Tipo de artículo: Solution
Última modificación: 26 jun 2023
Versión:  3
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