Dell EMC Unity: Upgrade to Unity OE 4.2 fails with error: check_cores_existed_files_2 (User Correctable)

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Síntomas

In Unity OE 4.2, some of the internal Unity partitions are resized, repartitioned, and reformatted.
In this case /cores was increased from 8G to 14G.


Unity upgrades from Unity OE 4.0 or 4.1 to 4.2 may appear to fail with this Pre Upgrade Health Check (PUHC) warning:

The health check has failed due to the presence of non-empty folders in /cores. Please run svc_dc to push files to the backend, run scp to back up files created by the service user, and rm to delete what remains. Retry the health check. If the problem persists, record the error code below and search the EMC Online Support website for available support options. 
[  Error Code: platform::check_cores_existed_files_2 ]

Causa

During the first upgrade from Unity OE 4.0 or 4.1 to Unity OE 4.2, some partitions will be reformatted in order to increase their size.

Resolución

This is a warning only, not an actual error, and therefore it would not fail the upgrade.
Pressing the "retry" button on the upgrade screen will resume the upgrade as expected.
Attention: pressing retry on the health checks screen will not change anything. This KB refers to the retry button on the actual upgrade screen:
kA2f1000000L4t4CAC_2_0
Please note: if the upgrade still fails after pressing the "retry" button, chances are there are some actual errors also. Make sure to investigate them by clicking on "Show (x) more errors" (just below retry) and resolving them. Again, only errors will actually fail an upgrade, not warnings.

Información adicional

The warning serves only to give the system administrator time to inspect the directory /cores/service (same as /home/service) in case some of the files here are required.
Generally speaking, files in this partition are not required. Any required file can also be downloaded from the SPs as backup.

ATTENTION: DO NOT move or copy any files to other directories or partitions within the SPs as this may lead to other space related issues, SP reboots, and even Data Unavailable. If any files are needed, download them off array, with a tool like WinSCP.

For info on how to download files form the secondary SP, please refer to KB 491071

If in doubt, please contact Dell EMC Technical Support or your Authorized Service Representative, and quote this Knowledgebase article ID. 

Productos afectados

Dell EMC Unity Family

Productos

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...
Propiedades del artículo
Número del artículo: 000052543
Tipo de artículo: Solution
Última modificación: 11 oct 2024
Versión:  3
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