Cómo limpiar los restos de Dell Threat Defense o Dell Endpoint Security Suite Enterprise

Resumen: Obtenga información sobre cómo eliminar los archivos sobrantes de Dell Threat Defense y Dell Endpoint Security Suite Enterprise mediante Cylance Cleanup Tool después de una actualización automática o en el lugar. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Nota:

Productos afectados:

Dell Threat Defense
Dell Endpoint Security Suite Enterprise


Causa

Estos archivos, si se omiten, pueden provocar una falla del sistema operativo, lo que indica una falla con CylanceDRV o CyPROTECTDrv.

Resolución

Estos restos pueden estar presentes en un escenario específico:

  • La versión del cliente Dell Endpoint Security Suite Enterprise o Dell Threat Defense se actualizó de 154x o anterior a la versión 156x o posterior.
  • Si el agente se desinstala, es posible que haya entradas y archivos restantes presentes después de actualizar a la versión 156x o posterior.

La versión 156x presenta un controlador rediseñado, que reemplaza a los controladores anteriores. Si el escenario anterior se ajusta a su entorno, se recomienda utilizar la herramienta Cylance Cleanup, que se puede solicitar al soporte de Dell, para evitar cualquier problema al reinstalar el agente de Dell Endpoint Security Suite Enterprise.

Nota: Estos pasos se aplican solo a Windows. macOS ESSE y Threat Defense 156x o superior no utilizan un controlador unificado.

Computadora local

  1. Extraiga CyCleanupSvc.exe y CylanceCleanupTool.bat al mismo directorio en la computadora de destino.
  2. Ejecute CylanceCleanupTool.bat como administrador.
  3. Una vez finalizada la limpieza, se creará un directorio de registros que contiene el archivo de registro con las tareas que realizó la herramienta.

Computadora remota (plataformas de administración, por ejemplo, SCCM, KACE, etc.)

  1. Asegúrese de que CyCleanupSvc.exe se distribuya a cada terminal.
  2. Para limpiar, ejecute lo siguiente mediante una herramienta de administración de sistemas, como Workspace ONE o System Center Configuration Manager de Microsoft, o con privilegios de administrador local o computadora local:
CyCleanupSvc.exe -install
  1. Una vez finalizada la limpieza, se creará un directorio de registros en la carpeta donde se encuentra CyCleanupSvc.exe, que contiene el archivo de registro que enumera las tareas realizadas por la herramienta. Este archivo de registro describe los datos que se modifican durante el proceso de limpieza.
  2. Una vez finalizada la limpieza, elimine el servicio Herramienta de limpieza de Cylance mediante la ejecución de lo siguiente mediante una herramienta de administración de sistemas, como Workspace ONE o System Center Configuration Manager de Microsoft, o con privilegios de administrador local o computadora local:
CyCleanupSvc.exe -uninstall

Equipo remoto (PsExec)

  1. Extraiga CyCleanupSvc.exe, CyCleanupSvc.exe.config y CylanceCleanupTool.bat en el mismo directorio de la computadora de destino
  2. En la computadora que no es de destino, abra un símbolo del sistema y ejecute el siguiente comando:
psexec COMPUTER -accepteula -nobanner -u USERNAME -p PASSWORD -s "C:\Path\To\CylanceCleanupTool.bat"
Nota:
  • Reemplace COMPUTER con el nombre de la computadora de destino.
  • Reemplace USERNAME con el nombre de usuario para iniciar sesión en la computadora remota.
  • Reemplace PASSWORD por la contraseña (opcional) para el nombre de usuario especificado anteriormente. Si no se proporciona ninguna contraseña, se le solicitará una.
  1. Una vez finalizada la limpieza, se creará un directorio de registros en la carpeta donde se encuentra CyCleanupSvc.exe que contiene el archivo de registro que enumera las tareas que realizó la herramienta. Este archivo de registro se puede recolectar si así lo desea.

Para comunicarse con el equipo de soporte, consulte los números de teléfono de soporte internacionales de Dell Data Security.
Vaya a TechDirect para generar una solicitud de soporte técnico en línea.
Para obtener información y recursos adicionales, únase al foro de la comunidad de seguridad de Dell.

Productos afectados

Dell Threat Defense, Dell Endpoint Security Suite Enterprise
Propiedades del artículo
Número del artículo: 000131776
Tipo de artículo: Solution
Última modificación: 01 jul 2024
Versión:  8
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