Gli switch Dell Networking serie OS6 N ottengono i registri ERR che tronca il valore intero > 32 bit

Resumen: Questo articolo spiega il messaggio di registro ERR che tronca il valore intero > 32 bit in Dell Networking OS6.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Viene registrato un messaggio nel registro, come mostrato di seguito per riempire i registri del buffer dello switch

General[procLOG]: l7_ns_mibs.c(XXXX) XXXXXXXX %% ERR truncating integer value > 32 bits

L'impatto sarà il seguente:

  • Non vi è alcun impatto funzionale sullo switch 
  • Si verifica un uptime errato durante il polling dell'uptime dello switch.
  • I messaggi di registro, come mostrato di seguito, riempiono i registri del buffer
Esempio di messaggio del registro
 
Mar 22 21:39:51 General[procLOG]: l7_ns_mibs.c(XXXX) XXXXXXXX %% ERR truncating integer value > 32 bits

Causa

  • Se il tempo di attività degli switch è superiore a 497 giorni, questo messaggio viene visualizzato quando viene eseguito il polling snmp per il MIB o l'OID precedenti
SNMP MIB : agentInventoryUnitUpTime
SNMP OID : 1.3.6.1.4.1.674.10895.5000.2.6132.1.1.13.2.2.1.14
  • Il motivo di questo messaggio di registro è dovuto al fatto che l'agent MIBInventoryUnitUpTime è Counter32, ovvero si tratta di un contatore intero a 32 bit. Se viene incrociato 497 giorni di uptime dello switch, il valore intero corrispondente supera i 32 bit e quindi gli overflow dei valori.

Resolución

Si consiglia di effettuare le seguenti azioni indicate di seguito.

    1. A partire dalla versione 6.8.1.1, il livello dei messaggi di registro è DEBUG anziché ERROR. Pertanto, possono essere upgrade a qualsiasi firmware alla versione 6.8.1.1 e successive.

     2. Interrompere il polling su   
SNMP MIB : agentInventoryUnitUpTime
SNMP OID : 1.3.6.1.4.1.674.10895.5000.2.6132.1.1.13.2.2.1.14
                                                                                      
     3. Riavviare lo switch in modo che il valore dell'uptime sia reimpostato.

Productos afectados

PowerSwitch N1100-ON Series, PowerSwitch N1500 Series, PowerSwitch N2000 Series, PowerSwitch N2100 Series, PowerSwitch N2200-ON Series, Dell EMC PowerSwitch N3000E-ON Series, Dell EMC Networking N3200-ON, PowerSwitch N4000 Series
Propiedades del artículo
Número del artículo: 000218453
Tipo de artículo: Solution
Última modificación: 12 oct 2023
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.