NVP-vProxy: No se pudo bloquear la máquina virtual para el respaldo: Hay otra operación de vProxy activa en la VM

Resumen: La integración de protección de VMware de NetWorker (NVP) está configurada con el dispositivo con vProxy. El respaldo de máquina virtual (VM) para algunas VM falla con un mensaje de error de consolidación. ...

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Síntomas

El registro de la sesión de respaldo de vProxy muestra lo siguiente:

YYYY/MM/DD HH:MM:SS INFO: Found virtual machine "VM-NAME" with MORef "vm-###".
YYYY/MM/DD HH:MM:SS NOTICE: Virtual machine "VM-NAME" requires consolidation of its virtual disks.
YYYY/MM/DD HH:MM:SS ERROR: Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS NOTICE: Snapshot "snapshot-###" of virtual machine "VM-NAME" (vm-###) was removed.

Los registros de sesiones de VM se encuentran en el vProxy en las siguientes categorías: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE

También puede encontrar los registros de sesiones de respaldo de máquinas virtuales (VM) en NetWorker Server:

  • Linux: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME
  • Windows (valor predeterminado): C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\
NOTA: Los registros de políticas de NetWorker siguen la retención jobsdb de NetWorker Server (72 horas predeterminadas). Una vez transcurrido el período de retención, los registros se eliminan de NetWorker Server, pero existen en el vProxy.

Causa

Un respaldo anterior finalizó de manera inesperada y los discos de instantáneas aún están montados en un dispositivo vProxy.

Resolución

Para resolver este problema, quite el disco de máquina virtual (VMDK) del dispositivo vProxy.

Opción 1:

Uso ProxyHC Para quitar los discos sobrantes y limpiar las sesiones obsoletas (si las encuentra).
Para obtener instrucciones sobre ProxyHC, véase: NVP-vProxy: Cómo usar la herramienta de evaluación del estado ProxyHC en el dispositivo
vProxyLas opciones de ProxyHC requeridas son las siguientes: ProxyHC disk tasks cleanup

Opción 2:

Quite los discos de VM del vProxy.

NOTA: Si no hay operaciones de respaldo o restauración de VM en ejecución, la VM de vProxy solo debe contener dos discos. 
ADVERTENCIA: Realice los siguientes pasos solo cuando no se estén ejecutando acciones de respaldo o restauración en el vProxy. Puede confirmar desde NetWorker Management Console (NMC), NetWorker Web User Interface (NWUI) o nsrwatch línea de comandos en el servidor de NetWorker.
  1. Inicie sesión en la interfaz web de vSphere.
  2. Haga clic con el botón secundario en el dispositivo vProxy de respaldo.
  3. Haga clic en Editar ajustes.
  4. Expanda todos los discos duros.
  5. Seleccione los discos duros que pertenecen a la máquina virtual que tiene el problema. Los discos duros de la máquina virtual deben mostrar el nombre de la máquina virtual en la ruta de archivo del disco:
    Ajustes del disco de VM de vProxy en vSphere 
  6. Haga clic en la X junto al disco duro para desmontar el disco duro de la máquina virtual.
    ADVERTENCIA: NO seleccione Eliminar archivos del almacén de datos.
  7. Haga clic en Aceptar.
  8. Consolide/elimine la instantánea en la VM mediante vSphere Web Client.

Información adicional

Propiedades del artículo
Número del artículo: 000195596
Tipo de artículo: Solution
Última modificación: 13 may 2026
Versión:  4
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