Avamar: Solución de problemas de fallas de recolección de elementos no utilizados (GC) (ruta de resolución)

Resumen: Avamar: Solución de problemas de fallas de recolección de elementos no utilizados (GC) (ruta de resolución)

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Las fallas de la recolección de elementos no utilizados (GC) se observan en la consola de Avamar Administrator y se informan en las salidas de status.dpn y dumpmaintlogs comandos cuando se ejecutan en el nodo de utilidad de Avamar.
 
Estos mensajes de error incluyen, entre otros:
  • MSG_ERR_BACKUPSINPROGRESS
  • MSS_ERR_DISKFULL
  • MSG_ERR_TIMEOUT
  • MSG_ERR_NOPARITY
  • MSG_ERR_MISC

 

El código de evento de una falla de GC es 4202.

Causa

La recolección de elementos no utilizados puede fallar por diversos motivos. 

Por lo general, hay un mensaje de error asociado con la falla que indica por qué falló la recolección de elementos no utilizados.

Esta ruta de resolución guía al lector a través de cómo solucionar los errores de recolección de elementos no utilizados según el error asociado informado. 

Resolución

Valide que cada paso de solución de problemas que aparece a continuación se pueda realizar en su entorno. En cada paso, se proporcionan instrucciones o un enlace a un documento para eliminar posibles causas y tomar medidas correctivas según sea necesario.

Paso 1: Recopilación de información
 
un. Inicie sesión en Avamar Utility Node como administrador y cargue las claves de administrador. Consulte Avamar: Cómo iniciar sesión en un servidor Avamar y cargar varias claves para obtener instrucciones sobre la carga de claves.
 
En el resto de este artículo de la base de conocimientos, se supone que las claves de administrador están cargadas.

b. Recopile toda la siguiente información que aparece en Avamar: Cómo recopilar la información necesaria para solucionar problemas de capacidad.  
 
 
Paso 2: Una sobrecarga alta de puntos de control puede hacer que la recolección de elementos no utilizados (GC) falle si la capacidad del sistema operativo (SO) es demasiado alta. De manera predeterminada, GC falla con MSG_ERR_DISKFULL si la capacidad del SO supera el 89 %. 

Verifique que no haya problemas de capacidad en la cuadrícula mediante 
Capacidad del SO de Avamar (ruta de resolución).


Paso 3: Se puede observar un tipo de problema de sincronización (Avamar v7+) con MSG_ERR_TRYAGAINLATER debido a ciertas tareas de Avamar que no pueden permitir que GC se ejecute simultáneamente. Consulte Avamar: La recolección de elementos no utilizados falla con MSG_ERR_TRYAGAINLATER.


Paso 4: Si la recolección de elementos no utilizados falla con MSG_ERR_GARBAGECOLLECT, consulte Avamar: error del código de síntoma 4202 >> : Recolección de elementos no utilizados fallida con error MSG_ERR_GARBAGECOLLECT.


Paso 5: Si la recolección de elementos no utilizados falla con MSG_ERR_BADTIMESYNC, consulte Avamar: código de síntoma 4202: recolección de elementos no utilizados fallida con error MSG_ERR_BADTIMESYNC


paso 6: Si la recolección de elementos no utilizados falla con MSG_ERR_DUPLICATE, consulte La recolección de elementos no utilizados de Avamar falla con MSG_ERR_DUPLICATE (v7.x)


Referencia:

Para otros mensajes de error de GC, incluidos MSG_ERR_TIMEOUT, MSG_ERR_DDR_ERROR, MSG_ERR_NOPARITY (o cualquier cosa que no se mencione en este artículo), comuníquese con el equipo de soporte de Avamar de Dell Technologies

El resto de los mensajes de error tienen soluciones solo internas.

Si encuentra otros problemas de capacidad que no son errores de GC, consulte Solución de problemas, problemas y preguntas de capacidad de Avamar: toda la capacidad (ruta de resolución).

 

Información adicional

 

Productos afectados

Avamar
Propiedades del artículo
Número del artículo: 000037107
Tipo de artículo: Solution
Última modificación: 08 jul 2025
Versión:  13
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.