NetWorker: No se puede instalar el software del servidor de NMC en el servidor de NetWorker de Windows o en el servidor de NMC dedicado
Resumen: No se puede instalar ni actualizar el servidor de NetWorker Management Console (NMC) en un host de Windows. El asistente de instalación de NMC muestra "No se puede verificar el nombre de host o el puerto del servidor de autenticación". ...
Síntomas
- NetWorker Management Console (NMC) está instalado (o se está instalando) en un host Windows.
- El asistente de instalación intenta verificar el servidor de autenticación de NetWorker que se utilizará para la autenticación de NetWorker.
- La instalación no puede validar el servidor de autenticación.
Unable to verify Authentication Server's hostname and/or port. If you were prompted, but did not install the certificate, try again by selecting view certificate and installing it under root certification authority. In no prompt was made for certificate validation, then verify that the NetWorker Authentication service is running on the configured host and port.

El servidor de NMC puede resolver el servidor de autenticación y conectarse al puerto de autenticación (valor predeterminado 9090). Comando de PowerShell:
tnc AUTHC_HOSTNAME -p 9090
La instalación manual del certificado del servidor AUTHC no resuelve el problema: NMC: La instalación falla con el error "No se puede verificar el nombre de host o el puerto del servidor de autenticación"
El archivo del servidor de autenticación authc-server.log Espectáculos:
- Linux:
/nsr/authc/logs/authc-server.log - Windows (valor predeterminado):
C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\authc-server.log
ERROR Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'dataSourceInitializer' defined in class path resource [serviceConfig.xml]: Invocation of init method failed; nested exception is org.h2.jdbc.JdbcSQLNonTransientConnectionException: Unsupported database file version or invalid file header in file "C:/Program Files/EMC NetWorker/nsr/authc-server/tomcat/data/authcdb.mv.db"
Causa
Daños en el AUTHC de NetWorker. El error específico que se observa en el authc-server.log puede ocurrir si NetWorker se actualiza realizando una desinstalación y, a continuación, instalando una nueva versión, en lugar de utilizar la opción "actualizar". La actualización de los archivos AUTHC no se manejaba correctamente con este método de actualización.
Resolución
Reinstale NetWorker con una nueva carpeta AUTHC para forzar el reemplazo de la existente.
Estos pasos no eliminan la configuración ni las bases de datos de NetWorker, no hay riesgo para los respaldos históricos.
- Apague NetWorker:
net stop nsrexecd /y - Desinstalar NetWorker (y NMC, si están en el mismo servidor)
- Cambie el nombre del
C:\Program Files\EMC NetWorker\nsr\authc-serverCarpeta - Instale NetWorker (esto crea una nueva configuración de AUTHC)
- Instalar NMC
Una vez finalizado, se deben iniciar los servicios y se puede probar el inicio de sesión de NMC.
Si la contraseña anterior de administrador de NMC no funciona, siga los pasos que se indican en para restablecerla. NetWorker: Cómo restablecer la contraseña del administrador
Información adicional
Si anteriormente reemplazó los certificados AUTHC o AD/LDAP integrado con el servidor AUTHC, estos ajustes se deben volver a configurar: