NVP-vProxy: La recuperación a nivel de archivos falla con el mensaje "No se pudo montar VMDK... Disco dinámico de Windows '\. PhysicalDrive4' está OFFLINE en la dirección SCSI 2/0/4/0
Resumen: La integración de NetWorker VMware Protection se configura con el vProxy Appliance. El flujo de trabajo de recuperación a nivel de archivos (FLR) no puede montar un VMDK, lo que indica que un disco dinámico de Windows está OFFLINE. ...
Síntomas
Se puede leer el siguiente código de error:
159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] SCSI address of disk '\\.\PhysicalDrive4' is: PortNumber 2, PathId 0, TargetId 4, Lun 0 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Checking 2/0/4/0 with 0/0/3/0 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Checking 2/0/4/0 with 0/0/4/0 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Slot 1 matches 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Windows Dynamic Disk '\\.\PhysicalDrive4' is OFFLINE at SCSI address 2/0/4/0. 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] FLR_ERROR: Windows Dynamic Disk '\\.\PhysicalDrive4' is OFFLINE at SCSI address 2/0/4/0. 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Cleaning up before exiting 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Mount error: exit status 1 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] Mount [0/3/0 0/4/0 0/5/0] failed: Windows Dynamic Disk '\\.\PhysicalDrive4' is OFFLINE at SCSI address 2/0/4/0. 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] :ENDLOG: 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [66] ====End of output from agent mount command. 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS INFO: [66] Unmounting after mount failure: Could not mount VMDKs [[EMC_FLR_NFS_DATASTORE] vm-8360-disk-key-2000.vmdk [EMC_FLR_NFS_DATASTORE] vm-8360-disk-key-2001.vmdk [EMC_FLR_NFS_DATASTORE] vm-8360-disk-key-2002.vmdk] onto VM '[VM_NAME]' (vm-8360) filesystems: [Unable to mount [0/3/0 0/4/0 0/5/0]: Windows Dynamic Disk '\\.\PhysicalDrive4' is OFFLINE at SCSI address 2/0/4/0.] ... 159373:nsrvproxy_flr: vProxy Log: YYYY/MM/DD HH:MM:SS ERROR: [66] Could not mount VMDKs [[EMC_FLR_NFS_DATASTORE] vm-8360-disk-key-2000.vmdk [EMC_FLR_NFS_DATASTORE] vm-8360-disk-key-2001.vmdk [EMC_FLR_NFS_DATASTORE] vm-8360-disk-key-2002.vmdk] onto VM '[VM_NAME]' (vm-8360) filesystems: [Unable to mount [0/3/0 0/4/0 0/5/0]: Windows Dynamic Disk '\\.\PhysicalDrive4' is OFFLINE at SCSI address 2/0/4/0.]
Causa
El respaldo de máquina virtual contiene discos dinámicos de Windows y se está recuperando en la misma máquina virtual. La recuperación a nivel de archivos de una máquina virtual con discos dinámicos de Windows se debe realizar en una máquina virtual de destino diferente desde el origen. La limitación se debe a que la máquina virtual tiene discos dinámicos de Windows con el mismo GUID cuando se montan los VMDK respaldados.
Resolución
Realice la restauración a nivel de archivos en una máquina virtual de destino diferente que no tenga un clon del disco dinámico de Windows. La información está disponible en la sección "Limitaciones de restauración en el nivel de archivos" de la Guía de integración de VMware con Dell NetWorker:
La restauración a nivel de archivos de máquinas virtuales con discos dinámicos de Windows es compatible con las siguientes limitaciones:
- La restauración solo se puede realizar cuando se realiza la recuperación en una máquina virtual diferente de la original. Además, esta máquina virtual no puede ser un clon de la original.
- Solo los usuarios administradores pueden realizar la restauración.
- Si las máquinas virtuales de Windows se crearon clonando o implementando la misma plantilla, todas estas máquinas virtuales de Windows pueden terminar utilizando el mismo GUID en sus volúmenes dinámicos.
Para su comodidad, toda la documentación de nuestros productos está disponible para su descarga en el sitio web de soporte de Dell en formato PDF. Cuando inicie sesión en el sitio web de soporte, simplemente seleccione la pestaña "Support by Product" e ingrese "NetWorker" en el campo "Find a Product by Name". Una vez que se encuentra en la página del producto NetWorker, seleccione el enlace Documentación para mostrar la documentación de NetWorker. Este es el enlace directo a la Guía de integración de VMware de Dell NetWorker https://support.emc.com/docu85873_NetWorker_9.2_VMware_Integration_Guide.pdf?language=en_US&language=en_US