Isilon OneFS 8.0: ファームウェア パッケージをインストールできません: /var/patch/backup:ディレクトリーではありません

Resumen: ファームウェア パッケージのインストールが完了しません。

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

ファームウェア パッケージのインストール中にインストールが完了せず、次のような出力が発生します。

# isi upgrade patches list

Patch Name                                          Description                                           Status
----------------------------------------------------------------------------------------------------------------------------------
IsiFw_Package_v9.3.5 Package Name  : IsiFw Package v9.3.5 2017-04-04 To... Installing

ステータスが「Installing indefinitely」と表示されます。

 

最後の数行を見てください。 /var/log/isi_pkg と表示されると、次のエラーが表示されます。

# isi_for_array -s 'tail -50 /var/log/isi_pkg'
.........
2017-05-28T13:31:56-05:00 <3.6> node-1 isi_pkg[16306]: Starting task for request 'INSTALL', task 'INSTALL_INIT', hash '2693c810637d37a02ee9cb57a9d01d3d'
2017-05-28T13:31:59-05:00 <3.6> node-1 isi_pkg[16306]: Running requirements file first for IsiFw_Package_v9.3.5..
2017-05-28T13:31:59-05:00 <3.3> node-1 isi_pkg[16306]: /var/patch/backup: is not a directory.
2017-05-28T13:31:59-05:00 <3.3> node-1 isi_pkg[16306]: install_init: Task encountered unknown failures

 

この問題は、 IsiFw_Package_v9.3.5.tarやIsiFw_Package_v10.0.1.tarなどのファームウェア パッケージで発生する可能性があります。

 

Causa

下にマウントされたパーティション /var ファームウェア パッケージなどの大きなパッチをインストールできるようにするには、 少なくとも40% の空きディスク領域が必要です。以下に十分な空きディスク領域がない場合: /varその場合、ノードは次のエラーでインストールに失敗します。

/var/patch/backup: is not a directory

 

Resolución

以下の条件でディスク使用量を削減 /var間のデッドロックが原因で潜在的なHMONタイムアウトが発生する問題が解決されています。通常、 /var/log トランケートする必要がある可能性のある大きなファイルを含むディレクトリ。これを判断するには、次のようにします。

  1. 次の 40% (容量は60%以下)の空き領域がないノードを特定します。 /var

    # isi_for_array -s 'df -h /var'
  2. 下に十分な空き領域がないノードにrootユーザーとしてSSHで接続します。 /var

    # cd /var/log
    # du ./* | sort -n -r | head -n 10
  3. 内部にバックアップ ディレクトリーを作成します /ifs/data/Isilon_Support/ トランケートされるファイルのバックアップを保存するには、次のようにします。

    # mkdir /ifs/data/Isilon_Support/Node<node number>_VarLog_Backup
  4. トランケートするファイルを新しいバックアップ ディレクトリーにコピーします。

    # cp  /ifs/data/Isilon_Support/Node_VarLog_Backup
  5. 手順2の出力では、次の上位10個の最大ファイルが表示されます。 /var/log間のデッドロックが原因で潜在的なHMONタイムアウトが発生する問題が解決されています。次のコマンドを使用してファイルをトランケートできます。

    # truncate -s 0 <filename>
  6. パーティションをもう一度チェックして、ディスク領域の 少なくとも40% (容量は60%以下)を解放していることを確認します。 /varです。

    # isi_for_array -s 'df -h /var'
  7. 十分な容量を解放したら、次のコマンドを使用して、失敗したアップグレードを再試行します。

    # isi upgrade retry-last-action --nodes=<lnn of failed node>
  8. アップグレード プロセスが完了するまで30分待ってから、パッケージのステータスが[Installed]になっていることを確認します。

    # isi upgrade patches list
    Patch Name                                               Description                                           Status
    ------------------------------------------------------------------------------------------------------------------
    IsiFw_Package_v10.0.1 Package Name  : IsiFw Package v10.0.1 2017-05-02 T... Installed

 

ファイルを安全にトランケートできるかどうかわからない場合、または下に大容量ファイルがない場合 /var/log だがしかし /var パーティションがまだいっぱいであるか、最後のアクションを再試行してもパッチのインストールが完了しない場合は、テクニカル サポートにお問い合わせください。また、このKBを参考にしてください。

 

Productos afectados

Isilon
Propiedades del artículo
Número del artículo: 000170772
Tipo de artículo: Solution
Última modificación: 29 jul 2025
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.