NetWorker vProxy backup mislukt met "RPC error: Kan geen verbinding maken met host " en "Err: 5037-Kan IP-adres van host niet oplossen "
Resumen: De integratie van NetWorker VMware Protection (NVP) is geconfigureerd met de vProxy Appliance. De vProxy-implementatie had enkele problemen met naamresolutie en DNS. De back-ups van de virtuele machine (VM) voor sommige virtuele machines mislukken met een foutmelding over ongeldige naamresolutie. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
In het bestand /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:
Van /nsr/logs/daemon.raw:
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR: [1268:7F4794001E30] ddp_connect_with_config_internal() failed, Hostname: 110DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR: [1268:7F4794001E30] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR: [1268:7F4778001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR: [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
---- Skipping Lines ----
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T13:59:20Z ERROR: [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:06:29Z INFO: [1268:7F476C001C80] ddcl_nfs_open_tcp - Timed out trying to resolve the hostname: DD###_T4
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR: [1268:7F476C001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR: [1268:7F476C001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
Van /nsr/logs/daemon.raw:
71193 MM/DD/YYYY HH:MM:SS AM 0 0 0 4988 4616 0 my_networker_server nsrd NSR info Media Info: Failed to start nsrsnmd on host my_storagenode_name, error `RPC error: Failed to connect to host 'my_storagenode_name': Remote system error - No connection could be made because the target machine actively refused it.
Zie Dell artikel 22793, NetWorker: Het gebruik van nsr_render_log
Causa
Probleem met naamresolutie op vProxy hostniveau
Resolución
Voeg handmatig het IP-adres, FQDN, korte naam van vCenter, Data Domain, NetWorker en Storage Node toe in /etc/hosts van vProxy Host.
Start nu vProxy VM back-ups.
Start nu vProxy VM back-ups.
- Meld u aan bij de vProxy PuTTY-sessie als beheerder en schakel vervolgens over naar root:
sudo su - root
- Voer de volgende opdracht uit om een /etc/host-vermelding te maken
# echo "IP_of_vCenter FQDN_of_vCenter ShortName_of_vCenter" >> /etc/hosts
MONSTER:
# echo "10.10.10.10 myvcenter.abc.com myvcenter" >> /etc/hosts
# echo "IP_of_DD FQDN_of_DD ShortName_of_DD" >> /etc/hosts
# echo "IP_of_NWServer FQDN_of_NWServer ShortName_of_NWServer" >> /etc/hosts
# echo "IP_of_StorageNode FQDN_of_StorageNode ShortName_of_StorageNode" >> /etc/hostsProductos
NetWorker FamilyPropiedades del artículo
Número del artículo: 000219162
Tipo de artículo: Solution
Última modificación: 23 oct 2024
Versión: 3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.